Jump to content


Photo
- - - - -

fiesta heater problem


  • Please log in to reply
2 replies to this topic

#1 octyvrs

octyvrs

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: fiesta
  • Location:

Posted 14 January 2009 - 09:07 AM

The heater in my wifes 2000 fiesta is blowing hot all the time,originaly it was blowing cold so changed thermostat,but did not cure problem so replaced heater control valve and now just blows hot all the time no matter what position the heater dial is in,had the control in car checked by sparky at work and he said it was ok,but when i replaced the hcv i got it off flea bay, not a ford part.all the problems with the heater appear to be with them blowing cold not hot, anyone have any ideas ?

Have something to contribute?

Sign in or register to start a topic...

#2 ikarma70

ikarma70

    Settling In Well

  • New Member
  • PipPipPip
  • 83 posts
  • Ford Model: fiesta 1.25 lx
  • Location:

Posted 14 January 2009 - 10:18 AM

did you test the hcv by hooking it up to the power to see if the solenoid works properly?

the solenoids can fail in either blowing hot or cold,a fully working solenoid will click open and closed,a bad 1 won't.

#3 octyvrs

octyvrs

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: fiesta
  • Location:

Posted 14 January 2009 - 05:22 PM

did you test the hcv by hooking it up to the power to see if the solenoid works properly?

the solenoids can fail in either blowing hot or cold,a fully working solenoid will click open and closed,a bad 1 won't.

No i did not try this as valve was new,to try this you disconnect from hcv turn ingnition on and reconnect and do you hear a noise or something ?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users