Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


TDCiST

Tdcist's Focus Zetec S Tdci

264 posts in this topic

sorry to hear this Dave, i hope your ok mate.

Share this post


Link to post
Share on other sites
 

Want to see potential screen damage?

Take a look at what i suffered today-

DSC_0074.jpg

Ouch!

Share this post


Link to post
Share on other sites

Clive, you stalking somebody? lol!

my neighbours windscreen smashed when we had heavy hail, the size of golfballs..it was incredible. he had the windscreen replaced and two weeks later a lorry crashed into the car...

Oliverb likes this

Share this post


Link to post
Share on other sites

Just got back from my local stealers with a couple of parts, started to get out of the car when the hail started.

Jumped back in sharpish I can tell you.

It even set car alarms off further down the road.

Share this post


Link to post
Share on other sites

Scary!


I remember heavy hail we had this was couple of years back... was worried it was going to damage the metalwork!!

Share this post


Link to post
Share on other sites

So for the second time now i have the Swinging Heater Needle syndrome...

I feel another trip to the dealer coming along....

Share this post


Link to post
Share on other sites

So for the second time now i have the Swinging Heater Needle syndrome...

I feel another trip to the dealer coming along....

The stock cooling system only works well under certain conditions anyway

Share this post


Link to post
Share on other sites

its strange... It gets to temperature, then after a few minutes, swings from normal to cold and back... every so often... never goes too hot!

Share this post


Link to post
Share on other sites

its strange... It gets to temperature, then after a few minutes, swings from normal to cold and back... every so often... never goes too hot!

Does it go too hot when/ straight after you "boot" it/ or sitting in traffic after a hard run?

Share this post


Link to post
Share on other sites

randomly unfortunately... sometimes it sits and swings while travelling steadily... sometimes I think it setlles when booting it, but other times it swings!!

I'm confused as it doesn't seem to have any consistency to it at all

Share this post


Link to post
Share on other sites

randomly unfortunately... sometimes it sits and swings while travelling steadily... sometimes I think it setlles when booting it, but other times it swings!!

I'm confused as it doesn't seem to have any consistency to it at all

As it is random/ If its the same as the Mondeo the temp is taken from a sensor on the head, so it is possible that the sensor or the connector going onto it are faulty, (or the wires etc further down the line) the ECU also uses this for cold start so may use more fuel and for detecting overheating so may even go into limp home mode (when the ECU "thinks" the engine is overheating when it is'nt) the other possibility is the temp really is fluctuating as the gauge displays (less likely- but a good reason to have a seperate temp gauge)

I remember reading there was a lot of complaints from some Fords so they "docktored" it to make it read "wrong" but looked "right" (if you know what i mean) i cant believe how cool mine runs on a cold day (ive only recently hooked up my digital temp gauge)

Its under warrantee anyway but im sure you will let us know how you get on

I was on your other forum and i saw a signature of a vax***l with a vented crankcase breather - never actually seen one mentioned before - ive got mine on a long pipe like a secondary exhaust (i dont like talking about other forums or vax***ls though :lol: )

Share this post


Link to post
Share on other sites

Hehe it's the place to be for diesel tuning! However I don't like to advertise it on other forums, tis rather ungentlemanly lol

FOCA likes this

Share this post


Link to post
Share on other sites

Update... Once again the dealer has said a loose connection caused the issue. After a little discussion it has been agreed that if (Dealers terms.. I used "When") it happens again then they will replace the temp sensor...

Share this post


Link to post
Share on other sites

Great looking car mate,

Didn't realise that you could fit the ST upper grille. Even though I've painted several for an other ST owners club's members!

I'm defo going to change mine.

You need to get the fog surround colour coded it makes a massive difference to the look off the car. I did mine and being white made a massive difference. Much cleaner look and makes the lower grill look much more menacing!

post-43850-0-89353000-1369430329_thumb.j

Oliverb likes this

Share this post


Link to post
Share on other sites

Hey F1, how did you do yours out of interest??

Well what to update...

I've had a new temp sensor... (At last)

I've got a whole car vibration between 60-70... Hoping its just a wheel balance issue and nothing serious!!

And that's it!

Really need to get my rear in gear with this st lower grille mod!!

Share this post


Link to post
Share on other sites

Dave,

the fog trims come out really easily an the round chrome trims do too. paint it and put it all back together and jobs done!

Share this post


Link to post
Share on other sites

Must be a pain to rub down and sand tho

Share this post


Link to post
Share on other sites

Use scotch pads. Makes it so much easier, I use it with soapy water to aid cleaning

Share this post


Link to post
Share on other sites

We'll the car has hit 3 years old now... MOT time! Passed, however it needed

4 new tyres, front discs and pads, and the temp sensor is still playing up... Ford have finally agreed to have the car as a project, and to investigate it fully! Means I'll end up with a lovely courtesy car I guess!

Share this post


Link to post
Share on other sites

We'll the car has hit 3 years old now... MOT time! Passed, however it needed

4 new tyres, front discs and pads, and the temp sensor is still playing up... Ford have finally agreed to have the car as a project, and to investigate it fully! Means I'll end up with a lovely courtesy car I guess!

It will be interesting to see what they find (if anything)

You don't seem to be on the forum that much recently

Share this post


Link to post
Share on other sites

Well...

Had a discussion today with the dealer... The car has been with them since Saturday, and they've had it apart...

It would seem part of the loom has abraded away and was shorting together every so often... So a new loom is being put in. Hopefully this should be the end of the heater gauge issues!

Share this post


Link to post
Share on other sites

good news. must not have been clipped in properly. could have been a lot worse though.

Share this post


Link to post
Share on other sites

Warranty fix? given that your just (only just) celebrating its 3rd birthday and they were aware of the issues from before it expired?

Share this post


Link to post
Share on other sites

Course it's a warranty fix.. I wasn't going to let them try and charge me lol!!

The issue seems to have basically told the PCM that the loom doesn't exist for the temp sensor... So a new loom was installed, and I need to play it by ear. Hopefully it's not a faulty PCM...

Sent from my iPhone using Ford OC mobile app

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now