Jump to content


Photo

Mondeo Tdci 2.0 115 Tickover Low


  • Please log in to reply
5 replies to this topic

#1 mondeotdcichris

mondeotdcichris

    Member

  • New Member
  • PipPip
  • 19 posts
  • Name: christopher
  • Ford Model: mondeo tdci
  • Year: 2004
  • Location: Yorkshire

Posted 18 December 2011 - 11:35 AM

hi does anyone know why my tickover is getting slower and slower its getting to the point now its ticking over at 700rpm and starting to judder, the car has covered 156000 miles and is still on its first set of injectors, i have tried injector cleaner etc and it dont work, just any ideas on what else it could be any help appreciated thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mondeotdcichris

mondeotdcichris

    Member

  • New Member
  • PipPip
  • 19 posts
  • Name: christopher
  • Ford Model: mondeo tdci
  • Year: 2004
  • Location: Yorkshire

Posted 18 December 2011 - 11:42 AM

tiping error on title its not 155 its 115.

#3 stef123

stef123

    Ford Enthusiast

  • Management
  • 5,871 posts
  • Name: Stefan
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 18 December 2011 - 11:44 AM

tiping error on title its not 155 its 115.


title sorted mate

#4 TDCiST

TDCiST

    No Smoke No Poke... Unless you have a DPF!

  • Moderator
  • 1,682 posts
  • Name: Dave
  • Ford Model: Ford Focus Zetec S 1.6 TDCi
  • Year: 2010
  • Location: Hertfordshire
Contributor

Posted 18 December 2011 - 03:08 PM

Dual Mass Flywheel starting to break up??

#5 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,560 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 18 December 2011 - 03:46 PM

it could be the egr valve gunked up, these can be cleaned and will only cost spanner time and some cleaner.

#6 mondeotdcichris

mondeotdcichris

    Member

  • New Member
  • PipPip
  • 19 posts
  • Name: christopher
  • Ford Model: mondeo tdci
  • Year: 2004
  • Location: Yorkshire

Posted 20 December 2011 - 02:19 PM

well my egr valve has been blanked off for quiet some time, i took the blanking plate back off today and it made no difference also my clutch feels fine, my last mondeo i had was the 2.0l tddi and flywheel went on that but could feel the problems with that when it went, this feels fine, could there be any other problems witch cause the tickover to slow down.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users