Jump to content


Photo

Satnav


  • Please log in to reply
8 replies to this topic

#1 tinks050

tinks050

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Name: Rick
  • Ford Model: Mondeo ST220
  • Year: 2006
  • Location: Devon

Posted 30 December 2011 - 08:25 PM

I recently purchased a new firmware and mapping update disc for my ford denso satnav, however after attempting to upgrade using the discs, the entire system wont turn on now (even with the old mapping disc back in). I have use of the climate control buttons around the outside of the satnav but nothing but a blank screen, no radio/CD, nothing. I would really appreciate some assistance. Thanks in advance.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 stef123

stef123

    Ford Enthusiast

  • Management
  • 5,878 posts
  • Name: Stefan
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 30 December 2011 - 08:28 PM

I wonder if it would help to disconnect the battery for a few moments to remove the permanent feed to the satnav? just a suggestion

#3 tinks050

tinks050

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Name: Rick
  • Ford Model: Mondeo ST220
  • Year: 2006
  • Location: Devon

Posted 30 December 2011 - 08:30 PM

I wonder if it would help to disconnect the battery for a few moments to remove the permanent feed to the satnav? just a suggestion



good idea ill try that mate, just wondered if anyone else has had this problem

#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,560 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 31 December 2011 - 02:43 PM

if that does not work you may need to get the original ford software re-installed, only ford and navteq sell the proper update discs and many copied discs just screw up the system, where did you get the update disc from?

#5 tinks050

tinks050

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Name: Rick
  • Ford Model: Mondeo ST220
  • Year: 2006
  • Location: Devon

Posted 31 December 2011 - 02:57 PM

if that does not work you may need to get the original ford software re-installed, only ford and navteq sell the proper update discs and many copied discs just screw up the system, where did you get the update disc from?


yeah i was afraid this may be the case, I bought them from a website called www.satnaviupdates.net. Seemed ok and the transaction was via paypal etc. I have since complained to them and they refunded me, I still have both discs. They never asked for them to be returned.

#6 tinks050

tinks050

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Name: Rick
  • Ford Model: Mondeo ST220
  • Year: 2006
  • Location: Devon

Posted 01 January 2012 - 12:31 PM

yeah i was afraid this may be the case, I bought them from a website called www.satnaviupdates.net. Seemed ok and the transaction was via paypal etc. I have since complained to them and they refunded me, I still have both discs. They never asked for them to be returned.

Tried disconnecting the battery for a couple of mins but still no joy, does anyone have an original ford disc I could borrow?

#7 DanDeliver

DanDeliver

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: Tim
  • Ford Model: Focus CC-3
  • Year: 2007
  • Location: Buckinghamshire

Posted 31 March 2012 - 06:15 PM

Sorry I can't help, I'm in the same boat. Have you found an original anywhere yet.?
Incidentally I've been speaking to Alex on TalkFord, who specialises in these things, who has offered to reflash my DVD Drive if I can remove it, but that's not so easy with a Focus. He has a Mondeo though, and may be able to help you.

#8 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 18,620 posts
  • Name: Clive
  • Ford Model: 2015 Focus ST3 250BHP
  • Year: 2015
  • Location: Devon
Contributor

Posted 31 March 2012 - 08:45 PM

Would this be of use to anyone?

http://www.ebay.co.u...=item1e6bf0e915

#9 btmaldon

btmaldon

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,587 posts
  • Name: Bruce
  • Ford Model: KA Edge, BMW 320i Coupe M Sport
  • Year: 2015
  • Location: Essex

Posted 01 April 2012 - 10:15 AM

I dont think that will work on the Denso system Clive. It looks like the disc for the Blaupunkt FX system in the Mk 2.5 Focus.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users