Jump to content


Show
Photo

Galaxy Wireing


  • Please log in to reply
2 replies to this topic

#1 dave h

dave h

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 58 posts
  • Name: David
  • Ford Model: Ford Maverick 2.7 Tdi GLS
  • Year: 1998
  • Location: Cambridgeshire

Posted 10 January 2012 - 11:37 AM

Hi i understand that the Galaxy did have a lot of electrical problems that was mainly caused by the ECU and wireing in the passenger side and alot off these cars had them replaced by a modofied one under warrenty. My question is does anyone know what year Ford started fitting the modified components at the factory. Many thanks Dave

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 NobbyB

NobbyB

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: Nigel
  • Ford Model: Ford Galaxy
  • Year: 1997
  • Location: Berkshire

Posted 10 January 2012 - 01:39 PM

Hi i understand that the Galaxy did have a lot of electrical problems that was mainly caused by the ECU and wireing in the passenger side and alot off these cars had them replaced by a modofied one under warrenty. My question is does anyone know what year Ford started fitting the modified components at the factory. Many thanks Dave


Hello, from what I recall, (stand to be corrected) there were a number of problems caused by the rear washer pipe leaking in the passenger footwell and flooding under the seat electronics. I wasnt aware that the components there were upgraded? I think these were parking sensor controllers in the main?

Hope this is a help.

#3 gregers

gregers

    Serial Poster

  • Budding Enthusiast
  • PipPipPipPip
  • 473 posts
  • Name: greg
  • Ford Model: smax titainium
  • Year: 2008
  • Location: Sussex

Posted 10 January 2012 - 07:56 PM

they moved the ecu from under the passenger seat to the bulkhead area,this is for the mk2
iirc the mk2 shap came around the year 2000.
peeps with the mk1 have done a bit of forward thinking and have made sure the rear washer pipe is conected very well and drilled a hole(being careful )under the ecu and installed washers to lift it.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users