Jump to content


Photo

1999 Focus Ghia 1.8 Tddi Engine Temperature

thermostat cooling heater engine not heating up

  • Please log in to reply
2 replies to this topic

#1 Robert Petch

Robert Petch

    Newbie

  • Members via FB
  • Pip
  • 1 posts
  • Location:

Posted 15 January 2012 - 05:51 PM

Hi, I'm a new member. I have a 1999 Focus 1.8 TDdi which has done 99'000 miles. I have had a lot of work done on it and it runs like a new car but recently I've noticed the temperature gauge isn't going up as far. The heater is luke warm. Under harsh acceleration the gauge seems to go up to halfway but when I take my foot off or slow down it drops to about 1/4 of the way up. Could this be the thermostat stuck open?? Thanks for any advice or help anyone can offer..... Robert

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon

btmaldon

    Ford Enthusiast

  • FOC Supporters
  • 2,552 posts
  • Name: Bruce
  • Ford Model: BMW 320i Coupe M Sport
  • Year: 2008
  • Location: Essex

Posted 15 January 2012 - 06:31 PM

It does sound like the stat is stuck open. Should be an easy fix. Good luck

#3 swhite87

swhite87

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 67 posts
  • Name: sebastian
  • Ford Model: Focus MK1 1.8 16V zeec
  • Year: 2001
  • Location: Caerphilly

Posted 06 March 2012 - 06:47 PM

either thermostat stuck or you have an airlock in the system


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




Also tagged with one or more of these keywords: thermostat, cooling, heater, engine not heating up

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users