Jump to content


Photo

Problems with heated front windscreen


  • Please log in to reply
4 replies to this topic

#1 Jonathan

Jonathan

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Focus
  • Location:

Posted 20 January 2009 - 06:26 PM

I've got a 06 plate Focus Zetec Climate which has developed a problem with the heated front windscreen.

When I switch it on to clear the screen before I drive I hear a knocking noise coming from the drivers side of the engine compartment. This does not seem to happen when the engine is warmer however I don't often have the need to use it then!

Does anyone know how I can fix this as it is particulary irritating.

Thanks in advance

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 SierraYankee99

SierraYankee99

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 859 posts
  • Ford Model: Ford
  • Location:

Posted 20 January 2009 - 11:27 PM

The only difference that the heated screen will make is the huge draw of power when its switched on. Cant really account for the knocking, could be alternator. You dont have the blowers on full demist too do you??? If you do that will be using the air conditioning too, could be air conditioning pump if you do.

#3 Jonathan

Jonathan

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Focus
  • Location:

Posted 21 January 2009 - 08:07 PM

The only difference that the heated screen will make is the huge draw of power when its switched on. Cant really account for the knocking, could be alternator. You dont have the blowers on full demist too do you??? If you do that will be using the air conditioning too, could be air conditioning pump if you do.

Thanks for this.

I bang the whole lot on when i get in, didn't know that i wasn't supposed to!

I will try it without the blowers and see if it still happens.

I don't fancy getting a new alternator/air con pump though, i was hoping that it would be an easy, cheap and well known fix.

#4 SierraYankee99

SierraYankee99

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 859 posts
  • Ford Model: Ford
  • Location:

Posted 23 January 2009 - 01:57 PM

I bang the whole lot on when i get in, didn't know that i wasn't supposed to!


You can do whatever you want to its your car lol. I'm just giving you possibilities for the cause of the noise you get.

#5 stuarthunt

stuarthunt

    Member

  • New Member
  • PipPip
  • 14 posts
  • Ford Model: Focus 1.6TDCi Zetec Climate
  • Location:

Posted 24 January 2009 - 09:51 AM

I have the same noise from my 07 plate Focus but it happens when I do not have the a/c on.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users