Jump to content


Engine Stalls On 97 Escort Ghia

  • Please log in to reply
No replies to this topic

#1 big col

big col


  • New Member
  • PipPip
  • 19 posts
  • Name: colin
  • Ford Model: escort 1.8 ghia x
  • Year: 1997
  • Location: Hertfordshire

Posted 12 February 2012 - 09:32 PM

hi all...my car just passed its m.o.t re-test after i replaced the lambda sensor...however, after i had driven it home, i went out in it again about 2 hours later...when i started the engine, it reved then died!, i tried again and it did the same, on the 3rd attempt it just managed to kick in...i also had occasions when the rev-counter went up and down a few times then stalled...today i stopped at lights and she stalled!, first time this has ever happened..in fact,i have NEVER had starting problems, until now

once the car is going she is as sweet as a nut.

all this happened after she had come out of the garage,(about noon on 11th feb)...i dont want to point fingers etc, but it is human nature to think as to why, but i dont want to make any waves, (unless i have too), until i can get some help and/or advice, on fixing it myself...i am not mechanically minded though.

thanks guys


Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users