• Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


Dave28

Fiesta Steering Wheel Controls Problem!

Recommended Posts

Hi,

Just wondering if anyone has had any intermittent faults with the steering wheel controls on the new fiesta?

I have the zetec s 10 reg.

Every now and again my left and right buttons sometimes dont respond when I want to switch music stations, music tracks etc.

Not sure if this could be a software issue or a loose connection.

I have been noticing this alot recently but the fault comes and goes so am not sure what it could be.

Any advice on this would be great.

Thanks

Share this post


Link to post
Share on other sites
 

i have a 2009 titanium and my skip back button is really really stiff and needs a good hard push to be used unlike the rest of the buttons are nice and easy no probs on my cruise control side ether.

Share this post


Link to post
Share on other sites

i have this exact same problem. The controls on the actual stereo still work when i have this problem. it is just every now and again the skip track buttons dont work. i don't see why it could be a software issue if the skip buttons on the stereo still work. Anyone had this fixed?

Share this post


Link to post
Share on other sites

Yeah the controls on the stereo work fine with me to.

I did book my car in a couple of months ago to get this checked but the technician could not replicate the issue as it is intermittent. They did tell me to book it back in so they could look into it further. I just have not got the time at the moment with work etc..

Would be interesting to know if this is a common problem.

Share this post


Link to post
Share on other sites

Got the same problem on my 2012 Zetec S. Control works when it wants. Multiple button pressing then it eventually fires into life. Should have asked the dealer to look at it last month when it was in for its second service :angry:

Share this post


Link to post
Share on other sites

Hello fiesta side of the world! ;)

My focus is doing the same :( Up doesn't always function and sometimes down also does up!!! Pulled up to some lights, went to put my music down and it rocketed in volume!

Share this post


Link to post
Share on other sites

Exact same problem, it just comes and goes. Mines is also zetec s 10 plate. I would put it down to a software gailt

Share this post


Link to post
Share on other sites

Had same problem on my last mondeo. Just put it down to dodgy electrics. My last and current Fiesta's are working fine.

Sent from my iPhone using Ford OC mobile app

Share this post


Link to post
Share on other sites

I had the same problem with my 11 plate zs went to the ford dealer and they replaced the buttons under warranty then they worked fine

Sent from my C6603 using Ford OC mobile app

Share this post


Link to post
Share on other sites

Had the same problem on my 13 plate Fiesta Zetec and now I've already noticed it on my 14 plate, and only had the car a week. Sigh.

Share this post


Link to post
Share on other sites

I think they have improved the buttons on the newer Fiestas, at least in by experience. On my 09 Titanium I had to press the cruise control on button quite firmly to make sure it came on. There were so many times when I thought it was on, then I get up to speed and try to set cruise on, and start slowing down lol, just cos the button didn't work. No such problem on the new ST.

Share this post


Link to post
Share on other sites

I get this alot on my 2013 Eco ZS I found that if you press the middle voice activation button then just press the skip track button after the sync woman is talking it un-glitches and works. Hope this helps

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

Had the same problem on my 13 plate Fiesta Zetec and now I've already noticed it on my 14 plate, and only had the car a week. Sigh.

Yep, same here, bought my 14 reg'd fiesta a month now and the wheel mounted volume controls are intermittent...looks like a trip back to the dealers then...

Share this post


Link to post
Share on other sites

Yep, same here, bought my 14 reg'd fiesta a month now and the wheel mounted volume controls are intermittent...looks like a trip back to the dealers then...

That should be covered by the warranty, so don't let them charge you for it ;)

Share this post


Link to post
Share on other sites

Mine did the same thing, but before I could take it in, the problem stopped just hope this doesn't happen again once the car is out of warranty

Share this post


Link to post
Share on other sites

I've a 2011 and it worked then didn't.....now there's nothing at all..... Don't want to take fords as may be expensive. I'm more concerned that my cig lighter is dead for powering my sat nav

Sent from my iPad using Ford OC

Share this post


Link to post
Share on other sites

I've a 2011 and it worked then didn't.....now there's nothing at all..... Don't want to take fords as may be expensive. I'm more concerned that my cig lighter is dead for powering my sat nav

If you can find a good independent garage they might be a lot cheaper than Ford. As for the cig lighter, that could just be a blown fuse.

Share this post


Link to post
Share on other sites

Just wondering if any of you with the problem have sprayed the steering wheel with any kind of cleaner and it's got in the buttons

Share this post


Link to post
Share on other sites

Had an Autodab fitted by a Ford dealer. All steering wheel controls work OK on DAB. When on FM/CD skip back button does not work (does on head unit). Thoughts anyone? Thanks.

Share this post


Link to post
Share on other sites

My + & - volume buttons are intermittent also. I can start the car and all works fine, I can start it again and the - vol doesn't work. Next start and the + vol doesn't work etc. This is progress?

I'm damn sure this hits a dealership before 12 months.

Share this post


Link to post
Share on other sites

^ I think the steering wheel buttons are just cheaply made. One of my volume buttons has started clicking after I press it, so wouldn't be surprised if it stops working.

Share this post


Link to post
Share on other sites

Joylonwagg, Are you turning autodab off and getting voice conformation of that, then try the buttons your having trouble with,

Share this post


Link to post
Share on other sites

Yer mines just started playing up on my fiesta Ecoboost Zetec S 1.0T 65/16 plate works when it wants to now n again can't answer phone calls volume works when it wants to voice button changes stations instead of giving voice commands lol cars under warranty till march 19 so will get it booked into dees of Croydon asap

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now