Jump to content


Photo

Air Conditioning Not Working


  • Please log in to reply
1 reply to this topic

#1 RS555

RS555

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Name: Dec
  • Ford Model: Fiesta Zetec Blue
  • Year: 2008
  • Location: Cheshire

Posted 22 February 2012 - 08:36 PM

Hi there seems to be a problem with my a/c on my 2008 mk 6.5 1.25 fiesta zetec as when I press the a/c button the light illuminates but nothing happens :blink: I read in a manual it will only operate above 4 Celcius but today it was 12 and still nothing. The engine revs arent dropping when i press the button and i've looked under the bonnet to see if the compressor is engaging and it is not. Also the radiator fan isn't starting with the turning on of the a/c (I read this should happen). Any ideas? I've tried it on every setting and checked connections under the bonnet and nothing seems array.

Thanks
Dec

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon

btmaldon

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,581 posts
  • Name: Bruce
  • Ford Model: BMW 320i Coupe M Sport, KA Luxury
  • Year: 2008
  • Location: Essex

Posted 23 February 2012 - 03:54 PM

May need a regass. If the pressure is too low, the system wont work.

You may have a leak in the system, but at 4 years old the system will be due a service anyway. Might be worth getting done.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users