AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


jack_routledge

Hids Fitting/install

3 posts in this topic

Hello.... I bought myself some HIDs for my Fiesta MK7, however the guide/diagram it a bit confusing, there are two very short black & red wires, im not sure if these are hooked up to the battery, because on one diagram is says they go to the battery and the other it says original socket. Im guessing its the original socket as surely they need to be hooked up to the standard wires somehow, so when i turn lights on they come on? Its the H7 bulbs, does anyone have any simple guides or advice/help, would be much appreciated. Thanks!

Share this post


Link to post
Share on other sites
 

They should connect right to the original wiring.

Plug'n'play.

Share this post


Link to post
Share on other sites

They will have spade connectors on each of the wires; one black, one red. They will plug directly into your existing wiring loom, the one you pulled off the back of your original bulb.

If you plug both wires into place and come to realise your lights arn't working, take the wires out and swap them over, that should solve the problem.

Sean.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now