Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Stables89

Help Engine Running Problems 1.6 16V Zetec Injection

3 posts in this topic

hi, i have a problem with my ford escort. when the engine is idlling its spluttery and jittery i came o the conclusion that its running on 3 cylinders. i removed the spark plug leads one at a time and the one on cylinder 4 is the only one that doesnt seem to have any effect on the engine when its removed (not firiing). but there is a spark coming from the lead.

im hoping that a new set of spark plugs will do the trick but noticed someone elses post on here from a few years ago that someone had the same problem and had to have their injectors cleaned and all sorts but still didnt solve the problem after changing the plugs and leads aswell. anyone know what else could be wrong or any tips incase changing the spark plugs doesnt work?

thanks in advance

Share this post


Link to post
Share on other sites
 

have a compression test done to rule out valve or head problems

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now