• Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience


Preee

Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

2,509 posts in this topic

My Car is 1.8 petrol versions...(2011)

have EHPS (electro hydraulic power steering system)

at menu list could't see any steering system setting.

could use ELMconfig or FF2 to open it or not?

It should be there to activate , also try checking the HEC page 2 (hec level) and adding sub levels up to 4 then you may see it in the menu.

As already stated car must be stationary before you cen change the setting.

Share this post


Link to post
Share on other sites
 

Tnanks reply ^_^ Preee :wub:

I have checked the HEC page 2 (hec level) and added sub levels up to 4.

Write, and restart this module.

But It's not work for me. :wacko:

Have any idea for me?

I didn't start engine.

Is this item need start engine? :(

It should be there to activate , also try checking the HEC page 2 (hec level) and adding sub levels up to 4 then you may see it in the menu.

As already stated car must be stationary before you cen change the setting.

Share this post


Link to post
Share on other sites

Normally you must be able to change the settings in the menu when the engine is running and the car is standing still.

Share this post


Link to post
Share on other sites

Normally you must be able to change the settings in the menu when the engine is running and the car is standing still.

Afaik the engine needs to be running but the vehicle stationary.

Share this post


Link to post
Share on other sites

It's not work :(

When engine running, the menu steering not appear :blink:

Anyone have any better suggestions ? :wub:

Afaik the engine needs to be running but the vehicle stationary.

Share this post


Link to post
Share on other sites

It's not work :(

When engine running, the menu steering not appear :blink:

Anyone have any better suggestions ? :wub:

Then you probably don't have that capability then.

Do you have a screen on flicking the menu tab that says 'your settings'?

The steering set up is usually there.

Scroll to your settings and then press in set if there you will see 'steering set up'

Share this post


Link to post
Share on other sites

You can download the software from http://www.psyence.co.uk/FDS.zip

Please be aware that this is still an early release, and it may not be 100% bug free. Please post suggestions, problems etc

Thnx

Hi, Psyence.

I used your software, but I found it seems a bug.

When I tick the DDS box and intent to write to HEC.

It shows "Download data from HEC first".

But I done it before I tick the DDS box.

Is anything I miss or wrong operation?

Thank you.

Share this post


Link to post
Share on other sites

Hi, Psyence.

I used your software, but I found it seems a bug.

When I tick the DDS box and intent to write to HEC.

It shows "Download data from HEC first".

But I done it before I tick the DDS box.

Is anything I miss or wrong operation?

Thank you.

same for me.is the new version ready yet ?

Share this post


Link to post
Share on other sites

Hi Roger

Can you write a program for the mk3 focus :-) i feel a bit left out lol

Jamie

Share this post


Link to post
Share on other sites
magican.gif

Share this post


Link to post
Share on other sites

Anything for a Mac user? ^_^

Share this post


Link to post
Share on other sites
Hi Roger Can you write a program for the mk3 focus :-) i feel a bit left out lol Jamie

Hi Jamie,

I am sorry about MK3 program because my country doesn't have MK3.

If MK3 sell in my country, actually I can, but I don't know the protocol for MK3.

Also I can't make sure the protocol MK2 is the same with MK3.

Meanwhile, I can capture the signal from logic analyzer to parser the MK2 or MK2.5 protocol.

But MK3, I am sorry I don't have any car to test.

Share this post


Link to post
Share on other sites

It's not work :(

When engine running, the menu steering not appear :blink:

Anyone have any better suggestions ? :wub:

Hi darkyeh,

I am the same with you.

Do you have any idea?

Share this post


Link to post
Share on other sites

Does anyone has idea to enable option on main menu?

I tried to set the EHPAS on ELM-FF2, also set the ELMConfig HEC page 1 and page 2.

As well as tick the submenu level 1 to 4 on HEC page 2.

So far it doesn't show the "Steering" option on my panel.

I confirmed my car has EHPAS, but why?

Somebody can help me~~Please :wacko:

Share this post


Link to post
Share on other sites

Hi

Try ELMconfig

HEC page 2 and add a couple of sub menu's see if it shows then

Share this post


Link to post
Share on other sites

Have you considered that it maybe your instrument cluster or ehpas module does not support steering modes.?

Like cruise control was not automatically supported.. Some models had cheaper modules from the factory which did not support cruise control.. Those aren't available from for dealers as spare replacements.. As dealers supply a 1 module fits all.. But in the factory to save a few pence they used different variants sometimes.. And if a car did not need a more expensive module they fitted the cheaper one.

Same is true of the instrument cluster.. The bottom spec model style? Which was dropped by ford had the rarer level 1 cluster, which was a single line LCD screen.. While most models had the larger screen..

Again things like DDS was only supported on level 2 instead of level 1

Share this post


Link to post
Share on other sites

Hi

Try ELMconfig

HEC page 2 and add a couple of sub menu's see if it shows then

Hi Preee,

Do you mean the circle as below??

NwZ1q.jpg

which submenu level should I tick?

BTW, there are some "Not used" items represent what??

Thank you.

Share this post


Link to post
Share on other sites

Have you considered that it maybe your instrument cluster or ehpas module does not support steering modes.?

Like cruise control was not automatically supported.. Some models had cheaper modules from the factory which did not support cruise control.. Those aren't available from for dealers as spare replacements.. As dealers supply a 1 module fits all.. But in the factory to save a few pence they used different variants sometimes.. And if a car did not need a more expensive module they fitted the cheaper one.

Same is true of the instrument cluster.. The bottom spec model style? Which was dropped by ford had the rarer level 1 cluster, which was a single line LCD screen.. While most models had the larger screen..

Again things like DDS was only supported on level 2 instead of level 1

Hi RB2004,

Thanks for your suggestion.

Why do I so ensurely that my car can enable these functions because I knew many cars had done which the cars type is the same with me.

But I will try to enable it. I just need some help, that's all.

Share this post


Link to post
Share on other sites

Hi, just an idea, but is it possible to add code reading to the software?

I don't know the technicalities.. But if you can directly interface with the module, download it's configuration, write new configuration or reconfigure its also possible to download error codes?

In some respects error codes would be more useful than switching on and off things lol just a suggestion.

Share this post


Link to post
Share on other sites

Also I can't make sure the protocol MK2 is the same with MK3.

FF3 protocol is completely diiferent than the FF2 one. FF2 use KWP2000/ISO15765, and FF3 use ISO14229, same as Mondeo IV, there central configuration is used. To change it you must first get a security access, then upload secondary bootloader in the module, then activate it and only after it you can upload a new central configuration.

Hi, just an idea, but is it possible to add code reading to the software?

I don't know the technicalities.. But if you can directly interface with the module, download it's configuration, write new configuration or reconfigure its also possible to download error codes?

In some respects error codes would be more useful than switching on and off things lol just a suggestion.

e76ff79e1fec.png

Share this post


Link to post
Share on other sites

Hi Preee,

Do you mean the circle as below??

NwZ1q.jpg

which submenu level should I tick?

BTW, there are some "Not used" items represent what??

Thank you.

Hi Preee,

Do you mean the circle as below??

NwZ1q.jpg

which submenu level should I tick?

BTW, there are some "Not used" items represent what??

Thank you.

Yes Mulder add upto level 3 see if it displays then.

Do the test mode and see what version your HEC is mine is version V508, test mode meaning the Dash trick to scroll through HEC data , it might be that your HEC version is not high enough

Share this post


Link to post
Share on other sites

Hiya Sergey how are you? , have you made any new updates recently?

Share this post


Link to post
Share on other sites

Hi,

Thanks for the bug report, i'll check it out and see whats wrong.

Psyence

Hi, Psyence.

I used your software, but I found it seems a bug.

When I tick the DDS box and intent to write to HEC.

It shows "Download data from HEC first".

But I done it before I tick the DDS box.

Is anything I miss or wrong operation?

Thank you.

Share this post


Link to post
Share on other sites

Hiya Sergey how are you? , have you made any new updates recently?

Hi Preee,

there was some small update (ELMConfig 0.1.1.8), it's availible through the previous link (http://civil.iffc.ru...g/ELMConfig.zip).

Changes:

- working with HCM module, including headlamp autocorrector calibration

- fix bug which appeared if the echo was already switched off in ELM327 settings

- the full bus loging during the work is now availible

- DllPack has gone in past, now universal RuntimePack with installer is used (all Windows versions) (http://civil.iffc.ru...RuntimePack.exe)

Share this post


Link to post
Share on other sites

Hi Preee,

there was some small update (ELMConfig 0.1.1.8), it's availible through the previous link (http://civil.iffc.ru...g/ELMConfig.zip).

Changes:

- working with HCM module, including headlamp autocorrector calibration

- fix bug which appeared if the echo was already switched off in ELM327 settings

- the full bus loging during the work is now availible

- DllPack has gone in past, now universal RuntimePack with installer is used (all Windows versions) (http://civil.iffc.ru...RuntimePack.exe)

Great news Sergey i will take a look :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now