• Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Preee

Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

2,517 posts in this topic

Looks like preee beat me to it again :)

On nightshift Willy so i'm up early lol :)

Share this post


Link to post
Share on other sites
 

i am completely lost with this, do i need to downlead elmconfig or just the link to the russian 1 on the 1st page? i downloaded the russian 1 then uploaded the drivers when the lead plugged into laptop, then plugged lead into car and input VIN, COM1 and bit rate then when i click online it comes up with an error box. any help?

Share this post


Link to post
Share on other sites

The link on the first page will download the latest version which has English Translation , you also need to download the Runpack.exe and run this on your PC to install required missing DLL fiiles this may be where your Error is coming from.

take a screen shot of the error your getting and post it so we can see whats happening.

Share this post


Link to post
Share on other sites

i downloaded the runtime do i need the elmCONFIG download?

Share this post


Link to post
Share on other sites

Apparently I do not have permission to download the English version of FF2

I am signed in - what do I need to do?

Share this post


Link to post
Share on other sites

Apparently I do not have permission to download the English version of FF2

I am signed in - what do I need to do?

Same for me . Even i am signed in, i have no permission for download.....

Share this post


Link to post
Share on other sites

I have made a few cables for people , downside is now i don't have a Mk2.5 to test it on anymore , i know Lennys Cable works :).

i'm keeping hold of my cable incase civil-zz manages to figure out the Mk3 Focus.

you say your cable is goosed ? , when you plug into laptop do the LED's light up at all?

Yes it does indeed light up and if I go on to Putty, the two LEDs flash properly. If you were up for it Preee, I could post it to you as I would imagine what I've done (whilst angry) is soldered the white wires to the wrong pins on the connector which goes to the car. If you had one which works perfectly, you'd probably be able to repair it. The holes are already made in the case for the wires to escape or for the switch to be installed.

I do still have the cable as I calmed down after an hour and pulled it out of the recycle bin - at the point of throwing it away I enjoyed the thought of it being melted down!

Share this post


Link to post
Share on other sites

anyone know what you select to enable the auto locking

I went into GEM and put 10 in the autolock if vehicle speed greater than this value

but it's not working

Share this post


Link to post
Share on other sites

anyone know what you select to enable the auto locking

I went into GEM and put 10 in the autolock if vehicle speed greater than this value

but it's not working

Here you go daz, tick these boxes first

post-5052-0-44753900-1355307822_thumb.jp

Share this post


Link to post
Share on other sites

Here you go daz, tick these boxes first

post-5052-0-44753900-1355307822_thumb.jp

nice one Willy

will pop back out

got it working fine enable dds so far

Share this post


Link to post
Share on other sites

great got the autolocking working now

did select eco mode in HEC level 2/3 but that doesn't seem to have worked

Share this post


Link to post
Share on other sites

great got the autolocking working now

did select eco mode in HEC level 2/3 but that doesn't seem to have worked

OK here's where you want to go Daz.

post-5052-0-39531700-1355309396_thumb.jp

Make sure you have a fully charged battery as the update takes about 40 minutes.

Turn off everything like anti virus, screen saver, wifi, power options as the laptop must stay on without any interruptions.

Share this post


Link to post
Share on other sites

OK here's where you want to go Daz.

post-5052-0-39531700-1355309396_thumb.jp

Make sure you have a fully charged battery as the update takes about 40 minutes.

Turn off everything like anti virus, screen saver, wifi, power options as the laptop must stay on without any interruptions.

what does that do Willy

only other thing I have noticed it says I am doing 11 mpg on the trip

do you just reset it

Share this post


Link to post
Share on other sites

It updates you speedo cluster to the latest version with enabled eco mode and shift light. I'm guessing you have a facelift as It's only compatible with the facelift.

Your mpg figures will be a bit off for a few weeks as the car has to relearn your driving style.

Share this post


Link to post
Share on other sites

It updates you speedo cluster to the latest version with enabled eco mode and shift light. I'm guessing you have a facelift as It's only compatible with the facelift.

Your mpg figures will be a bit off for a few weeks as the car has to relearn your driving style.

yeah I have a 59 plate facelift

all sorted and updated.

did crap myself tho because it failed the 1st time and my complete cluster wasn't working but did it again and it completed in 19 min

did turn the laptop screen off half way through for 5 min or so.

is there any info on the eco mode coz it says see manual

Share this post


Link to post
Share on other sites

Hi, I have a modified ELM327 device that I've successfully modified my 2011 Focus ST, auto lock, seat belt reminder alarm, etc.

So I decided to try it on my C-Max (58 plate). Well, it will read the GEM info and that’s about it. Can't get the VIN or anything else to work, read configuration. Just get errors. Any ideas welcome, tried a couple of times, Focus ST is fine, same laptop & software ELMConfig 0.2.3, same configuration.

Thanks

Share this post


Link to post
Share on other sites

Apparently I do not have permission to download the English version of FF2

I am signed in - what do I need to do?

I asked Steve to take a look at the files , so can you test them now to see if they download /

Share this post


Link to post
Share on other sites

I asked Steve to take a look at the files , so can you test them now to see if they download /

still the same

Share this post


Link to post
Share on other sites

Is there a setting for the autolocking if you stop and open say passenger door for it to relock again when you driving off without switching off and on again

Share this post


Link to post
Share on other sites

Is there a setting for the autolocking if you stop and open say passenger door for it to relock again when you driving off without switching off and on again

It will auto relock when you drive faster then the selected speed if you check the "auto relocking" box.

Share this post


Link to post
Share on other sites

It will auto relock when you drive faster then the selected speed if you check the "auto relocking" box.

Pretty sure i have that ticked already will check tomorrow

Share this post


Link to post
Share on other sites

As my car has Eco mode (since programming the first time round at the weekend) does this mean I don't need to run the update?

Only asking as I do not have the green arrow, but not necessarily going to do anything as a full software update if it isn't going to actually benefit me at all.

Share this post


Link to post
Share on other sites

Have you marked the ' shift up indicator ' option..... Configuration / page 1 / ELM Config ?

Share this post


Link to post
Share on other sites

In all honesty, I've probably neglected to do that.

When the cable arrives on loan from Lenny I shall take a closer look.

I don't even use the Eco mode, I just like lights coming on. I like to feel like I'm a pilot when I drive....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now