Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Preee

Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

2,493 posts in this topic

i cant seem to put the option to change my steering through the menu with the elm config. i have a modifed cable.

what do i need to click to enable this.

i have a 1.8 mk2.5

at the minute i have enabled the tyre pressure, auto locking, stereo ondash.

has anyone changed to eco, adaptive or sport.

whats the difference/change?

Share this post


Link to post
Share on other sites
 

i cant seem to put the option to change my steering through the menu with the elm config. i have a modifed cable.

what do i need to click to enable this.

i have a 1.8 mk2.5

at the minute i have enabled the tyre pressure, auto locking, stereo ondash.

has anyone changed to eco, adaptive or sport.

whats the difference/change?

I thought the 1.8 petrol had the steering option already? , is this just for cars with the electronic steering.

Share this post


Link to post
Share on other sites

guys, i recently finished modifing the elm, however i run into trouble. When i connect the cable to the car, none of the programs work. I've followed my checklist, however i receive a "CAN ERROR".

* I've installed the drivers on the computer including the RuntimePack.

* I've set the port to COM1 (Speed 38400)

* I've been using this port and speed in all programs (ELMConfig, ELM-FF2_EN, FDS)

* I've connected the cable to different usb ports

* I've tried all three available states on the switch.

Any suggestions or instructions would be much helpful.

Also, i am still a bit confused overall. My questions are as following:

1. Why do we need the switch? What is the use of each state?

2. Which program should i use in order to read the configuration of the car and make alterations? (ELMConfig, ELM-FF2_EN, FDS)

3. Do i need to follow the instructions for Putty before the programs in order to establish a connection with the car?

Thank you in advance.

This is my attempt attachicon.gif2013-07-24-925.jpg

1. You need the switch to be able to switch between MS-Can ( GEM) and HS-Can (HEC) , the ELM is set to HS_Can by default before being modified.

2. All three programs work.

3. Putty was only needed on ELM-FF2 , on ELMConfig civil.zz created a quick button to action the same cammands as Putty.

Can error - You need to double check your wiring if none of the programs are working

Share this post


Link to post
Share on other sites

I thought the 1.8 petrol had the steering option already? , is this just for cars with the electronic steering.

It did have the steering selection on now it has gone?????

I restored to original but doesnt seem to change it back. The car is stopped handbrake on and still doesnt appear. I wonder if i clicked or unclicked something by accident.

Share this post


Link to post
Share on other sites

any one know why this happens and why the elm cant run at that speed ?

attachicon.gifelmhec.jpg

John i think this is related to the ELM chip , and believe some of the cables work and some don't , my very own cable i have will not configure to 5000000 , where as some of the new one's i have modified seem to accept the speed , but i have not tested if they actually work as i don't have a Mk2 focus to test it on.

Share this post


Link to post
Share on other sites

It did have the steering selection on now it has gone?????

I restored to original but doesnt seem to change it back. The car is stopped handbrake on and still doesnt appear. I wonder if i clicked or unclicked something by accident.

I have seen this before , try un-ticking HEC one at a time , first try EPB and DDS tick box , and if that does not solve it then same page Shift up indicator/ hill hold menu

Share this post


Link to post
Share on other sites

Ok will do cheers dude

Any info on the adaptive/eco/sport ?

Share this post


Link to post
Share on other sites

Ok will do cheers dude

Any info on the adaptive/eco/sport ?

Im not sure Gareth , it might be to set the default position for the steering for ignition on.

Share this post


Link to post
Share on other sites

John i think this is related to the ELM chip , and believe some of the cables work and some don't , my very own cable i have will not configure to 5000000 , where as some of the new one's i have modified seem to accept the speed , but i have not tested if they actually work as i don't have a Mk2 focus to test it on.

i could always test them for you :rolleyes:

Share this post


Link to post
Share on other sites

i could always test them for you :rolleyes:

haha :lol:

Share this post


Link to post
Share on other sites

Can error - You need to double check your wiring if none of the programs are working

None of the programs work. When i de-soldered the wires from 6 and 14, i put them directly on the two middle connectors switch. Isn't that the correct place?

I'll check my connections and possibly re-solder everything...

Share this post


Link to post
Share on other sites

yes it is the correct place , but from your picture it is hard to tell if the other wires are in the correct position on the plug end.

Can Error , usual suspect is incorrect wiring.

Share this post


Link to post
Share on other sites

Can anyone help with this little one? I disabled seat belt warning with IDS/VCM but it turned off the light and the chime. I just wanted to disable the chime but there is no option for this with VCM/IDS. For a genuine Ford tool it is very limited with some things.

I have been playing with ELM config but can't find a way of turning the light back on. Any ideas? I have looked in all the modules and played with lots of difference settings but to no avail!

Share this post


Link to post
Share on other sites

Ok will do cheers dude

Any info on the adaptive/eco/sport ?

The Adaptive/ECO/Sport setting are for automatic transmission only. This setting influences the shifting behaviour of the automatic gearbox. It has also effect on the response of the throttle pedal. (the throttle pedal is directly connected to the instrument cluster which converts the signal to CANbus).

This setting can also be applied on vehicles with manual transmission. If you change the setting to Sport the throttle response will be a little bit better (more direct). On my 1.6 100 HP engine it has a positive effect.

Share this post


Link to post
Share on other sites

ive sorted it, steering is now back on. i had shift up indicator (level 1) / hill hold ticked.

taken it off and its visible now.

Share this post


Link to post
Share on other sites

Unfortunately its not possible to disable just the chime, its an all or nothing thing unfortunately!

Share this post


Link to post
Share on other sites

Unfortunately its not possible to disable just the chime, its an all or nothing thing unfortunately!

For the MK2 it is not possible indeed to only deactivate the belt minder chime.

For the MK2.5 it is possible to only deactivate the chime with ELMconfig. If you do this the belt minder light will be still working. To do this you have to go to the 3rd configuration page of the instrument cluster (HEC) and deselect the "Belt Minder" tickbox.

Share this post


Link to post
Share on other sites

It finally works! I changed the switch and rewired the cables to it. The switch suggested in the first page is great because you can easily fit it on the main body with no visible cables!

Now i have some more questions:

1. Using the ELMConfig, when i try to access some options, i get an error about the speed. I increased the speed from 38k to the max on the drivers config, but then the program wouldn't connect. I then switched the speed back to 38k and only changed the speed on the program, and even tho the speed test said it was supported, i received an error.

2. When i try to write the config for HEC using FDS, i get an error saying that i need to read HEC first.

3. I activated DDS and it is shown on the dash. I went to its menu and held "set" to reset the values. Should i do anything else, or is it safe to assume that it is working fine? I do not get any readings and there is only an option to reset the values again.

Share this post


Link to post
Share on other sites

see on youtube you can activate power fold mirrors on the ford focus RS via elm but done see any option...

Share this post


Link to post
Share on other sites

see on youtube you can activate power fold mirrors on the ford focus RS via elm but done see any option...

It is possible to fold the Focus MK2.5 electric folding mirrors automatically when the car is locked/unlocked but this can not (yet) be done with an ELM327 interface and ELMconfig.

To make this function work your car must be already equipped with the electric folding mirror option. Normally when pressing the manual switch of the electric folding mirrors it sends a signal to the door modules which control the electric folding mirrors. To make the mirrors fold automatically when the car is locked/unlocked the firmware of the door modules needs to be updated to a custom made version.

Some clever Russians have written custom firmware for the MK2.5 door modules but this firmware is not available for free. I know it is available as a paid feature of the Russian UCDS interface and software which is available for about €90,-. At the moment I do not think there are other ways to get the custom firmware. Some Dutch people own the UCDS interface and I consider buying one myself. Compared to the free ELMconfig software it has a few nice features and as far as I know it is the only interface which is capable to program / change setting of the Focus MK3.

Share this post


Link to post
Share on other sites

I own a mk2 ford focus RS, i have the power fold button inside my car but doesnt fold when pressing the lock button on the remote

got any links on where i can purchase this software/ code

Share this post


Link to post
Share on other sites

With reference to the seat belt reminder. With all the options that are available there must be a way of having the light come on but not the chime?

post-45038-0-12982600-1374956914_thumb.j

post-45038-0-12152400-1374956915_thumb.j

post-45038-0-02546800-1374956916_thumb.j

These screen shots were done in off line mode but does anyone which ones should be ticked to enable it again because I turned mine off with VCM/IDS I don't know which ones should be ticked!

With reference to this next picture, I am thinking that if one of these options are enabled it would allow you access the full menu options while the car is being driven. I just want to have "messages" accessible while the car is in motion. I did think that just selecting "sub menu level 3" would do this as it is the third option on the instrument cluster menu but enabling it didn't change anything.

post-45038-0-83980000-1374956916_thumb.j

Anyone else done this or tried to do it?

Finally a bit of a random one. I enabled DDS, ECO mode and anti hijack today on a 2011 car. Everything went fine on the programming side but when turning the ignition on after finishing it came up with "engine malfunction" This stayed on after cycling the ignition. I checked the DTC fault codes and there were lots there all unrelated to what had just been enabled. I cleared the codes, it went away and it has been fine.

Anyone else had this happened before? I have done a few cars this week and messed around with mine loads but never seen this.

Thanks

Ben

Share this post


Link to post
Share on other sites

JW, anymore info on the UCDS? Is it like VAGCOM but for Fords?

Share this post


Link to post
Share on other sites

I've been reading this thread for year every now and then but still I am a bit confued and though I could ask... Is there currently way to enable cruise control for PCM module without Ford IDS, using elmconfig? If I can configure my adapter to high enough speed...

I know that elmconfig has now flashing capabilities, but screenshots etc. I saw had nothing related to CC. Is this possible? I have enabled CC in evey other module and replaced steering wheel and checked that all the wires etc. are in place and "test mode" will give me beeps when I press CC buttons on steering wheel... But it does not work. It's not enabled in PCM. Will elmconfig help me?

How about this UCDS? It's still cheaper than taking my car to Ford carage for IDS...

Thanks and sorry for asking :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now