Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Preee

Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

2,509 posts in this topic

Hi Swen,

You might be able to get away with it, but I dont believe it will work.

Share this post


Link to post
Share on other sites
 

Today I installed a new instrument cluster for FF2 MK2,5 on my car, a FF2 MK2 1.6 TDCi 110 HP. I installed firmware version 512AK and saw that I can not set the steering (I have electro hydraulic power assisted steering) to comfort, sport or normal, because these option is missing on the menu. Also, I think that the average consumption is higher the cluster which I had before. Any ideas to solve the problem? Is a matter of firmware?

Thanks !

Share this post


Link to post
Share on other sites

Hi folks

a new version of FoCCCus is available

FoCCCus_0.8.2 is the vers number

Jamie

Lenny likes this

Share this post


Link to post
Share on other sites

Anyone still have the modified ones for sale?

Or anyone with one in Northern Ireland, near Belfast.

Wouldn't mind my car auto locking and the radio display on the front cluster.

Mark...

Share this post


Link to post
Share on other sites

I have a spare one but it doesnt write to instrument cluster. DezWez I believe was selling them, although I dont think he has a stock, if you drop him a message he might be able to assist.

DMB1 likes this

Share this post


Link to post
Share on other sites

I remember back in my VW days on one of the forums was a list of guys who had the VAG version of this, their location, the capabilities of the hardware/software they had and their 'contribution' fee for helping members out with diagnostic checks, activation of certain conveniences etc. Would it be possible to do the same for this on this forum? Im not lazy, or a numpty and will probably attempt this at some point but time is my enemy. However, Id be quite happy to give someone £10 say to turn on automatic front heated windscreen, would save me a load of grief next winter!

Anyway, just and idea. Means those that cant still get the benefits and those that can get reimbursed for their efforts.

Let me know your thoughts, happy to help putting a list/table together.

Cheers,

Rob

Share this post


Link to post
Share on other sites

Hi Rob,

I did start a thread on "What could you share" in the general chat section I believe, for people to do just this. if you wanted something, see if anyone around could help you out. I live in Kent, so if you are often up here (unlikely as it may be) I would be happy to help out.

Share this post


Link to post
Share on other sites

Anyone still have the modified ones for sale?

Or anyone with one in Northern Ireland, near Belfast.

Wouldn't mind my car auto locking and the radio display on the front cluster.

Mark...

There are forum ones available in the Smaxownersclub.
DMB1 likes this

Share this post


Link to post
Share on other sites

Hi,

i bought a elm device last week and follow the process to modify it.

all is working fine and i have no prblem accesing and activating the options i wanted.

i just have one question regarding the hill hold assist feature.

i tried to activate it but it deosen't seem to work.

i ticked 2 boxes on the elmconfig pages, tried on a street nearby but didn't see any difference.

does it require a special element in the car ?

do i missed a box to tick ?

if someone who have make it work can give me some advice, it would be great.

i have a ford kuga, diesel 2.0 140hp 2WD, manual shift

thanks

Share this post


Link to post
Share on other sites

You need to activate it via the trip computer as well. As I recall, you need to switch the options on via the ELMConfig, but you do need to check that its active via the trip computer switch.

Share this post


Link to post
Share on other sites

it doesn't appear int he trip menu

i have ESP, and several other menu, i checked everyone but no option available.

i must have forgotten something in the activation

just checked the indication in the offline mode : Shift Up Indicator (level 1) / Hill Hold Menu (MPS6) (Level 2/3)

i checked ont he internet for MPS6 info and it seems to be the "powershift gearbox".

does it mean that it works only with this gearbox ? (mine is manual)

Share this post


Link to post
Share on other sites

It would need the ps6 on the cluster firmware but if it's not in the right area of the gem it won't work.

Sent from my MY SAGA C2 using Ford OC mobile app

Share this post


Link to post
Share on other sites

yes sorry resistors not capacitors

Share this post


Link to post
Share on other sites

It would need the ps6 on the cluster firmware but if it's not in the right area of the gem it won't work.

Sent from my MY SAGA C2 using Ford OC mobile app

do you mean that i need to update my cluster firmware ?

or just activate something ?

how can i do that ? using elm adapter i suppose, but where can i get the file to update it ?

Share this post


Link to post
Share on other sites

to be honest I havent seen any further updates for the instrument cluster beyond those for the MK2.5 Focus cluster (version 10 or 12 I believe?) and that is updated via the ELM Config software.

If the GEM has it setup then this could be the last piece of the puzzle, but before you do that, try stopping the car on a hill and firmly push the brakes (not just gentle) hold them there for a few seconds and as you let go you should find it holds you for a few momentary seconds.

Share this post


Link to post
Share on other sites

i tried again tonight, nothing.

when i relaese the brake and no hold activated...

but something else is funny

i tried to modify the steering configuration (sport / confort / normal) but the menu isn't anymore in my odb...

i think i have tick something (or unticked) that made it disappear (i had it previously) so i'm thinking i done something "wrong" and it's maybe why i don't find the hill hold menu...

i backed up every page before modifying so i will be back to factory settings and be more careful (1 @ a time) to be sure evrything ok.

i'll let you know

Share this post


Link to post
Share on other sites

Hill Hold Assist does only work with the Powershift transmission. All other Focus MK2/MK2.5 (and also C-max MK1/MK1.5 and Kuga MK1) transmission types do not support the Hill Hold Assist functionality.

Selecting the "ECO Shift-up" setting on a car which does not support it often makes the power steering menu disappear. Your problem may be caused by this setting.

Lenny likes this

Share this post


Link to post
Share on other sites

ok thanks for the answer

too bad for the hill hold it's very useful

eco has been activated ;-)

i will disable it (not very useful anyway)

Share this post


Link to post
Share on other sites
Hi Folks.

Greetings from Brazil.


I've been using ELMConfig on my Focus MK2,5 and after that i realized the temperature gauge has been modified.

Originally (from factory) the gauge reaches 90ºC when REAL temperature was around 45°C. (could check it on Torque app for Android)

Now the gauge shows the exactly real temperature.


Is there any config on ELMConfig that I could put it back from factory?


Thanks, and sorry for my bad english.

Lenny likes this

Share this post


Link to post
Share on other sites

Hi Tobias,

Your english is very good so dont worry!

As for the updates, did you save all the pages before you changed the settings? its the first rule to download and save a backup config before you play with the software!

Share this post


Link to post
Share on other sites

all is working fine again :)

got back my steering parameters

got rid of the eco mode

thanks again for the advice

Share this post


Link to post
Share on other sites

Hi Tobias,

Your english is very good so dont worry!

As for the updates, did you save all the pages before you changed the settings? its the first rule to download and save a backup config before you play with the software!

Unfortunately i forgot to read-and-save files to my PC.
But i've just clicked read from HEC, flagged the "reverse warning" and save to HEC. No other changes.
And now my temp gauge is modified.

Share this post


Link to post
Share on other sites

Best bet is probably to restore the car via the AsBuilt.

Share this post


Link to post
Share on other sites

Hill Hold Assist does only work with the Powershift transmission. All other Focus MK2/MK2.5 (and also C-max MK1/MK1.5 and Kuga MK1) transmission types do not support the Hill Hold Assist functionality.

Selecting the "ECO Shift-up" setting on a car which does not support it often makes the power steering menu disappear. Your problem may be caused by this setting.

Hill hold assist is in my car which is manual

Jamie

Share this post


Link to post
Share on other sites

\perhaps it merely is a note of config and having the instrument cluster support it as the final piece of the puzzle.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now