AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Preee

Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

2,493 posts in this topic

Hill hold assist is in my car which is manual

Jamie

Your car is a Focus MK3. This topic is about the Focus MK2/MK2.5, C-max and Kuga. On the Focus MK2/MK2.5, C-max and Kuga the Hill Start Assist function was only available on cars with the Powershift transmission. On the Focus MK3 the Hill Start Assist function is also available on some other transmission types.
james_60 and Lenny like this

Share this post


Link to post
Share on other sites
 

Hi,

I have one question. I have been able to modify ELM and connect MS-CAN modules. Also, I have activated Windows Global Opening Enabled and Windows Global Closing Enabled in GEM->Configuration->Page 2. Everything went OK and rereading parameters shows that mentioned is active. But when I long press Lock or Unlock on the key, nothing happens. Isn't it supposed to close (long press on Lock on remote) and open (long press on Unlock on the remote) the front windows? Thanks.

Regards,

Gabrijel

Lenny likes this

Share this post


Link to post
Share on other sites

think you need all 4 window to be electric for it to work

Russ likes this

Share this post


Link to post
Share on other sites

+1

Global open/close only functions on a car with all electric windows.

Share this post


Link to post
Share on other sites

Hi all will elm config work on a ford fiesta mk6 2007 I need to programme the gem module.

Share this post


Link to post
Share on other sites

wired691 , No ELMConfig will not work on a Fiesta

Lenny likes this

Share this post


Link to post
Share on other sites

+1

Global open/close only functions on a car with all electric windows.

think you need all 4 window to be electric for it to work

Aha, so that's the catch! Thanks guys! I have only front motorized windows.... Will have to revert back activated options.

Gab.

Share this post


Link to post
Share on other sites

If you have door control modules in the front ......it will work.

My S-max has manual rear windows......the front doors have modules in them, so the global feature works on them.

Sure same would apply to Focus.

Still have to do it the old way on the back windows :)

Lenny likes this

Share this post


Link to post
Share on other sites

If you have door control modules in the front ......it will work.

My S-max has manual rear windows......the front doors have modules in them, so the global feature works on them.

Sure same would apply to Focus.

Still have to do it the old way on the back windows :)

Hi Richiemac,

what exactly do you mean by "door control modules in the front"? That would be some additional module in the doors or some option that only needs to be activated?

Gabrijel

Lenny likes this

Share this post


Link to post
Share on other sites

Best bet is probably to restore the car via the AsBuilt.

Thank you so much!

I restored via AsBuilt and now everything is working fine!

Share this post


Link to post
Share on other sites

I've had a couple of ELM units and various rocker switches sat here for ages and finally taking the plunge to wire one up and play with some software now I'm all laptopped up too.

Just didn't think there'd be quite so many pages to sift through this topic to make sure I'm working to the latest info :o

Share this post


Link to post
Share on other sites

remember to back up everything yes lots of reading to do :)

Share this post


Link to post
Share on other sites

Hi guys,

I tried this week-end to assemble (on Focus facelift 2008) the two sensors for the Passenger Seat (C31 socket: pin 11 and 12) and Belt Minder (C31 socket: pin 19 and 20) and unfortunately some strange errors("Timed Out") are returned when activation is done with ELM-config . As I looked closer I noticed the wiring diagram for the facelift(beside pre-facelift) is different: The passenger mat(in the chair) is no longer connected to the RCM module(Pin 33)?!

Thus, for the activation to be completed the option 'Belminder Simplified Architecture' is required?

The two sensors are listed here: http://postimg.org/image/j8gjoival/

The activation options from RCM using ELM config: http://postimg.org/image/8uz0h3her/

The RCM electric scheme: http://postimg.org/image/qehy1yxj3/.

Thank you!

Lenny likes this

Share this post


Link to post
Share on other sites

Quick question on modding the ELM cable - originally got some nice chunky 3-position rocker switches but can see fitting a mini switch into the unit looks a lot better.

In my bits and pieces I've got a double pole 6-pin mini switch but it's 2 position rather than 3 - does this actually matter? I'm expecting it just means the unit would then always be set to HS or MS can, is the Off position even needed?

Share this post


Link to post
Share on other sites

nope, as long as there is HS and MS thats all that matters, no point in having an off switch.

troy45 likes this

Share this post


Link to post
Share on other sites

That's great, cheers :)

Have now fired up the soldering iron and dived in without quite reading the info properly first time :rolleyes:

Share this post


Link to post
Share on other sites

haha, good luck then, you might find you need to do a bit of solder - desolder if you jump too quick but good luck with it and hopefully you can get all the benefits from it! :)

Share this post


Link to post
Share on other sites

Got there ok eventually, just a bit of juggling act having enough length in the switch wires to work with but then also get the box back together.

Maybe get it onto the car tomorrow depending on time :)

Share this post


Link to post
Share on other sites

good result! was it an electric or butane iron you used?

Share this post


Link to post
Share on other sites

Plain old electric soldering iron, nothing fancy but it does the job, has served me well for years :)

Did have a butane one but just couldn't get it to work.

Share this post


Link to post
Share on other sites

Had a crack at using my modified ELM327 on the car today.

Didn't go completely smooth, seemed to get some No Data issues and MS-can not working - double checked all the connections were wired right and with a bit more digging I found I had to take baud rate off auto detect before it would let me set the unit for MS-can but got there eventually.

Will take me a bit of time to find out what is useful to alter. So far I've got ESP option activated on the cluster menu, Driveaway locking, enabled approach/puddle lights to see if I can get power from this at the mirror connection. Found in the ACM menu that my car was set up for fabric interior so updated that and I set Radio info enabled on the cluster which doesn't seem to do anything?

Also somehow now the car beeps like crazy when it's in reverse, will be turning that one off pronto :rolleyes:

Anyone know how the puddle lights usually operate so I can do some voltage checks?

Cheers

Lenny likes this

Share this post


Link to post
Share on other sites

Puddle lights are active after unlock and until auto relock I believe, radio info requires the right firmware on the mk2.5 cluster.

Sent from my MY SAGA C2 using Ford OC mobile app

Share this post


Link to post
Share on other sites

Thanks for the info there - I'll pull some trim off tonight then and check some voltages for the mirrors, plus see what firmware the software says I have on my cluster.

Just reading up now on the firmware update :)

Share this post


Link to post
Share on other sites

Being lazy I've not looked up what the Focus RS setting on the HEC? does.

I assume it doesn't turn my car green and take some horsepower off it?

:P

Lenny likes this

Share this post


Link to post
Share on other sites