• Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


Preee

Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

2,517 posts in this topic

nah it just disables the innappropriate options for the RS...

Lenny likes this

Share this post


Link to post
Share on other sites
 

I have started to remove the hated EPB from my 2006 C-Max Ghia, starting with the interior console and working to the outside later, and a few days ago I "took the plunge" and having bought a ready-modified Elm cable I went into the car menus, followed the advice on here and unticked the EPB boxes. All went well and thankfully I no longer have the persistent messages on the dash display advising of total EPB failure but have I removed everything I should have? I still have the electric switch connected and if I remove the key from the ignition without remembering to hold the switch down the EPB starts to operate automatically. Can this "auto application" be removed using the Elm, or will it need different software?

Have to say, all the advice on here has been brilliant and a great help. I would never have thought of attempting anything like this in the past, so much respect to all involved!! :)

Lenny likes this

Share this post


Link to post
Share on other sites

not sure that you can disable it altogether with elm, you need to remove it from the HEC, GEM and probably the ECU.

Sarge likes this

Share this post


Link to post
Share on other sites

Ok, thanks for that jeebowhite, appreciate it.

Share this post


Link to post
Share on other sites

no problem, good luck and do let us know if it works!

Share this post


Link to post
Share on other sites

I've finally got rid of the damned EPB, thanks to the team at Station Garage in Kintore........I supplied the new parts and they did the hard bit!!! I had already used the advice on here to remove the EPB from the dashboard, which got rid of the various warning messages, but I never did find out if I could stop the auto-application when removing the key as I ran out of time before the car went in to the garage. Anyway, it's sorted, and what a great feeling being able to use a normal handbrake once again! :D

Share this post


Link to post
Share on other sites

result!

So what was the total cost?

Share this post


Link to post
Share on other sites

Do you know if this works for the fiesta?

Share this post


Link to post
Share on other sites

No, the Fiesta MK7/MK7.5 are not supported by the ELMconfig software. As far as I know there is no such specific software for the Fiesta.

Share this post


Link to post
Share on other sites

There is ELM FFN for fiesta and fusion mk6.5 only. I used it and works. Not as good as this though...

Sent from my iPhone using Ford OC mobile app

Share this post


Link to post
Share on other sites

Hi i have a ford focus ST2 09 plate what is needed to enable the global open and close as i have tried ticking the boxes on the eml config program but it doesn't seem to work? also if i enable the radio information cd track information and the phone incoming call information will it work as i only have the small screen where the speedo is? iv managed to get the shift light to work which is cool :) and the auto locking is also working.

Share this post


Link to post
Share on other sites

Don't know about the global closing as my car already had it enabled.

For the radio, CD and phone info it works with the small LCD display - it makes room by only showing full mileage and trip on one screen page instead of every one. Mine shows radio station same as on the head unit (but not for DAB??) then it'll show track number for CD's and so far only seen it say 'Phone' when the phone is selected. Also gives volume level briefly when you adjust it, again same as the head unit.

Share this post


Link to post
Share on other sites

Hi i have a ford focus ST2 09 plate what is needed to enable the global open and close as i have tried ticking the boxes on the eml config program but it doesn't seem to work? also if i enable the radio information cd track information and the phone incoming call information will it work as i only have the small screen where the speedo is? iv managed to get the shift light to work which is cool :) and the auto locking is also working.

Hi,

if you are speaking about global windows opening and closing, then check info on page 136 of this topic:) I had similar "problem" and the answer is that electronic door module (or something like that) is missing. Beside that, looks like all doors must have electronic opening/closing of the windows.

Gabrijel.

Share this post


Link to post
Share on other sites

no new update since may for focccus program :-(

Jamie

Share this post


Link to post
Share on other sites

Correct me if I'm wrong but with ELM327 software and cable I can remap EGR to not giving me error after EGR blanking?

Share this post


Link to post
Share on other sites

Not that I am aware of, the 1.6 CMAX is mechanical anyway so you shouldnt have an issue with the warning light after you blank it off.

Share this post


Link to post
Share on other sites

Hi guys,

Please help . I got some problem to enable the steering mode with elmconfig for my Ford Focus 1.8 Ghia (Duratec He) year 2006. I did follow the instruction to uncheck the check box Shift Up Indicator Level 1 then Write to HEC at Page 1 of HEC module. After that I check the check box for HEC Level 2/3, Trip Computer, Main Menu, and Submenu level 4 at Page 2 of HEC module. When I try to write to HEC it throw an error instead. Where do i miss... :(

Share this post


Link to post
Share on other sites

Hi Mel, did you backup before you changed the settings?

Share this post


Link to post
Share on other sites

Hi James,

Yes, I did backup before change the setting..

Share this post


Link to post
Share on other sites

in which case, reload the backup you made and apply it to the car, that will get it back to a working state.

if its a petrol engine then it will have standard hydraulic steering I believe, which does not have the optional 3 operation modes.

Share this post


Link to post
Share on other sites

Hi James,

Owh, sorry not to mention that i had backup after when i had change my car battery. So its already reset everything and I just got its default configuration. I'm not very sure is my car before this already got steering mode on the dashboard or not.. Yes my car is a petrol engine. Its quiet messy everytime I want to change the steering mode / auto transmission mode I need to connect manually with my usb OBD to my laptop and configure it by using elmconfig... The steering and autotransmission really work/response when changing the mode manually..

Share this post


Link to post
Share on other sites

The instrument cluster probably doesnt have the capability to support it on the firmware, although I am surprised plugging it in allows you to change the setting. Are you sure it really changes the setting?

Share this post


Link to post
Share on other sites

Only the 1.4 and 1.6 Duratec and 1.6 Duratec TI-VCT Petrol engines have the conventional hydraulic power steering system.

All other engine types do have the EHPAS (Electric Hydraulic Power Assisted Steering). On the EHPAS system the steering caracteristics can be set to Comfort, Adaptive or Sport. The settings menu should be present in the instrument cluster menu. If not the instrument cluster is not configured properly. My experience is that selecting some options also affects other settings/options.

You should first try to restore the instrument cluster settings to the Original factory settings. If no backup is available the original settings can be recovered by the vehicles AS-BUILT data. In most cases this solves the problem.

I suspect your problem is related to the shift indicator. If I understand correctly you deselected the following option:

Shift Up Indicator (level 1) / Hill Hold Menu (MPS6) (level 2/3).

This is not the correct setting to solve your problem. This option activates the shift up indicator on a level 1 instrument cluster. A level 1 instrument cluster is the most basic instrument cluster without trip computer. The level 1 instrument cluster was only available on very low spec vehicles for certain markets. A level 2 instrument cluster is the most common one and has the smaller trip computer display. The level 3 instrument cluster has the large trip computer display which is used for satnav or automatic transmission.

The following setting is known to make the EPHAS menu dissapear:

ECO Shift Up (on the HEC level 2/3 settings).

I suspect deselecting this options will solve your problem.

bacchaito likes this

Share this post


Link to post
Share on other sites

Hi James,

Yup maybe it's does't support on the current firmware.. Yes it work perfectly when i change the steering / auto-transmission mode.

Hi Wilco,

I do read some article regarding my focus generation. Here some link that can be describe the specification of my focus generation

http://www.autoworld.com.my/v2/news/nb_details.asp?awCatId=RT.ATC.CAR.BTW&awReviewID=2006&whichpage=9. The car do have EHPS system..

I will try your suggestion tomorrow morning and will feedback to you again.

Share this post


Link to post
Share on other sites

If I am right you drive an Asian Focus MK2. The Asian Focus MK2/MK2.5 are different from the European Focus MK2/MK2.5. For example the instrument clusters are produced by a different manufacturer and use different firmware. Possibly the Asian instrument cluster (or its firmware) do not support the EHPAS settings menu.

I previously owned an Asian MK2.5 instrument cluster which did not work correctly in my European Focus MK2. The AS-BUILT data was different and the instrument cluster did not support some of my cars functions. Note that ELMconfig is designed and tested for Russian/European Ford models which are different from the Asian models. Some of the functions of the program may not be compatible. Updating modules with the wrong firmware or even selecting the wrong settings may result in bricked electronic modules.

bacchaito likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now