Jump to content


Photo

Glow Plug Problem Help!


  • Please log in to reply
4 replies to this topic

#1 Nathalbin1988

Nathalbin1988

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: Nathan
  • Ford Model: Mondeo
  • Year: 2004
  • Location: Dorset

Posted 11 March 2012 - 06:03 PM

Hello im new to this so trying to find some advice/success stories lol

I have a 54 mondeo tdci 2l done 106,000 miles
Owned it a year now had no probs an let it run really low on fuel as could get to a petrol station, so glow plugs started flashing filled it up with diesel an carried on with my journey.
Driving up the duel carridge way within 10 mins car goes in to limp mode an cuts out, was told rev the engine get the crap out the system so i did an it was fine.
Next day driving over 50 car goes into limp mode, but only when i put foot to floor not if take it steady, got home changed fuel filter an filled up with fuel an put reddex in with fuel.
Car is ok to drive but as soon as put foot down goes into limp mode an shuts down no power engine cuts out have to turn off an turn back on.
Took it to garage had diagnostic as when engine goes into limp mode glow plugs an engine management lights flash.
Anyway diagnostic came back two codes p1211 an p0251,
Had fords diagnostic done an was told injector pump by them?
Now reading some of these posts im thinking could it be the injector pump or maybe just a valve in that as car still starts an runs ok but shuddery at starting but still ok

Thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 18,553 posts
  • Name: Clive
  • Ford Model: 2015 Focus ST3 250BHP
  • Year: 2015
  • Location: Devon
Contributor

Posted 11 March 2012 - 06:19 PM

p1211 is not listed but p0251 is injection pump fuel metering control "A" (cam/ rotor/ injector).
Sounds like the injectors may have got crap in them - that's probably why you were advised to rev it so as to hopefully clean the obstruction.
I'd run some injector cleaner other than redex E.G BG244 http://www.powerenha...el-fuel-cleaner through the system and see if that helps, if not then check the injectors for damage or blockages and the new fuel filter for crap.
I reckon the limp is caused by a lean fuel condition.

#3 Nathalbin1988

Nathalbin1988

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: Nathan
  • Ford Model: Mondeo
  • Year: 2004
  • Location: Dorset

Posted 11 March 2012 - 06:29 PM

What does lean fuel condition mean?

The codes were injector control pressure above/below desired
And injector pump fuel metering control malfunction
Thats what the garage gave me :(

How do i check the injectors will garage have to do that?


#4 Nathalbin1988

Nathalbin1988

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: Nathan
  • Ford Model: Mondeo
  • Year: 2004
  • Location: Dorset

Posted 11 March 2012 - 06:35 PM

And thanks will buy some now see if that works

#5 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 18,553 posts
  • Name: Clive
  • Ford Model: 2015 Focus ST3 250BHP
  • Year: 2015
  • Location: Devon
Contributor

Posted 11 March 2012 - 06:47 PM

Lean condition basically means you're not getting enough fuel into the engine, it will run fine at low revs but will not give enough fuel at higher revs or when the engine is under load e.g revving hard.
BG244 will clean your whole fuel system but unlike redex will not strrip lubrication from the turbo and engine.



Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users