Jump to content


Engine Cutting Out

  • Please log in to reply
1 reply to this topic

#1 Peter54321



  • New Member
  • Pip
  • 1 posts
  • Name: Peter
  • Ford Model: Ford Maverick Mark 2/Escape 2 ltr
  • Year: 2001
  • Location: Shropshire

Posted 18 March 2012 - 12:20 PM


I have a Ford Maverick/Escape 2001 3ltr V6 24v and I am having problems with it. The engine will idle but when you try to accelerate it cuts out and will not restart for approximately 1 hr. Then it will start and idle again if you try to accelerate it immediately cuts out. It has new coil packs, crank sensor and cam sensor and does not show a Ford fault code when diagnostics are run with a code reader.

Could you offer any advise at all?

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Z3 MON


    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 328 posts
  • Name: David
  • Ford Model: Ford Mondeo 2.0 TDCI 115 Mistral 2004
  • Year: 2004
  • Location: Surrey

Posted 19 March 2012 - 01:17 PM

blocked fuel fitler, blocked fuel pipe, kined fuel pipe or a leak in the fuel line or something

it sounds like only enough fuel is getting through to start and idle but the moment you accelerate there isnt enough fuel to carry the revs so its dying due to lack of fuel.

might be wrong though.

When was it last serviced?
has it been standing for a long time?
has it been in a an accident?

check the fuel lines carefully

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users