Jump to content


Photo

Fluid Leak


  • Please log in to reply
10 replies to this topic

#1 fintious maximus

fintious maximus

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 110 posts
  • Name: Andy
  • Ford Model: Modeo Estate 2.0 Zetec
  • Year: 2001
  • Location: Yorkshire

Posted 19 March 2012 - 06:50 PM

Hi all,

noticed a small pool (5ch diameter) of fluid under the car this morning and dabbed a finger in it. Fluid is pinky watery stuff with no strong smell. Had a look under the engine and from the front of the car, the left hand side at the bottom is what I think is power steering pump (?) which has a belt on it and is the lowest pulley of the set on that side of the engine.

a. is that the power steering pump and

b. is that likely to be the leaky culprit?

Can't see where the leak is coming from but the pulley housing is wet underneath.

Thanks in advance

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 18,587 posts
  • Name: Clive
  • Ford Model: 2015 Focus ST3 250BHP
  • Year: 2015
  • Location: Devon
Contributor

Posted 19 March 2012 - 08:41 PM

Sounds like hydraulic fluid to me, so probably power steering.
Look at your power steering reservoir under the bonnet, are the colours / texture the same?
You can't miss the reservoir, it has a symbol on top of it like a steering wheel.

#3 fintious maximus

fintious maximus

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 110 posts
  • Name: Andy
  • Ford Model: Modeo Estate 2.0 Zetec
  • Year: 2001
  • Location: Yorkshire

Posted 20 March 2012 - 08:27 AM

checked that last night and they do appear to be the same. PS reservoir is full though?

#4 pragmatix

pragmatix

    Too much time on the boards

  • FOC Supporters
  • 579 posts
  • Name: Pete
  • Ford Model: Mondea 2Ltr Tdci Titianium Estate
  • Year: 2008
  • Location: Perthshire

Posted 20 March 2012 - 08:46 AM

Waht colour is your coolant, I ask because mines a pinky colour, if it was hydralic fluid it would have an oily feel

#5 Z3 MON

Z3 MON

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 328 posts
  • Name: David
  • Ford Model: Ford Mondeo 2.0 TDCI 115 Mistral 2004
  • Year: 2004
  • Location: Surrey

Posted 20 March 2012 - 10:28 AM

I recon its coolant aswell, could it be your water pump ???

#6 fintious maximus

fintious maximus

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 110 posts
  • Name: Andy
  • Ford Model: Modeo Estate 2.0 Zetec
  • Year: 2001
  • Location: Yorkshire

Posted 20 March 2012 - 04:25 PM

It is also similar to coolant but the level hasn't changed in there either. If it is water pump is it a big job?

#7 Z3 MON

Z3 MON

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 328 posts
  • Name: David
  • Ford Model: Ford Mondeo 2.0 TDCI 115 Mistral 2004
  • Year: 2004
  • Location: Surrey

Posted 20 March 2012 - 06:00 PM

It might be just the hose going onto the pump has come losse or has da slight split, probably near or under the clip that holds the pipe on judging by the minimal leakage

#8 fintious maximus

fintious maximus

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 110 posts
  • Name: Andy
  • Ford Model: Modeo Estate 2.0 Zetec
  • Year: 2001
  • Location: Yorkshire

Posted 20 March 2012 - 06:12 PM

Got the day off tomorrow so ging to get jacked up (and axle stands) to see what I can find. Just as a pointer, where is the water pump? Not got a Haynes yet...

#9 stef123

stef123

    Ford Enthusiast

  • Management
  • 5,871 posts
  • Name: Stefan
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 20 March 2012 - 08:03 PM

Got the day off tomorrow so ging to get jacked up (and axle stands) to see what I can find. Just as a pointer, where is the water pump? Not got a Haynes yet...


its driven off the auxiliary belt.

#10 Z3 MON

Z3 MON

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 328 posts
  • Name: David
  • Ford Model: Ford Mondeo 2.0 TDCI 115 Mistral 2004
  • Year: 2004
  • Location: Surrey

Posted 21 March 2012 - 07:17 AM

Drivers side :)

#11 fintious maximus

fintious maximus

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 110 posts
  • Name: Andy
  • Ford Model: Modeo Estate 2.0 Zetec
  • Year: 2001
  • Location: Yorkshire

Posted 26 March 2012 - 06:48 PM

Havn't had chance to get under yet but have noticed that the last 5 days there has been no leak! Could it have been overfilled and water was expelling from expansion tank drain? All levels are perfect

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users