Jump to content


Photo

Cruise Controlhi


  • Please log in to reply
1 reply to this topic

#1 dwodr

dwodr

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: john
  • Ford Model: mondeo
  • Year: 2005
  • Location: Worcestershire

Posted 22 March 2012 - 06:05 PM

Hi all. Just got a mondeo 2.2 tdci ghia x. Used the cruise control once and no problems but now has ceased to function. I am fairly competent with the spanners and wondered if there is any common faults before a garage emptys my wallet. Bought the car with warranty but the dual mass spat its dummy the other day and the warranty company will only pay for that to be fixed and the garage are only worried about profit. So while the novelty factor is still there lets get it fixed.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 20,976 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 23 March 2012 - 10:20 AM

Hi John,

I would say that regardless, the car is under warranty, and if you have bought the car with a fault, then your garage should honour the repair, otherwise, I would suggest that they need to sort it out or take the car back as it is not fit for purpose!

As for the faults, what happens when you try to switch it on, do you get any lamps appear, anything clicks?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users