Jump to content


Photo
- - - - -

fiesta 96


  • Please log in to reply
4 replies to this topic

#1 dode09

dode09

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: fiesta
  • Location:

Posted 30 January 2009 - 01:03 PM

Hi,

i have a fiesta 1.25 8V P Reg.

It keeps stalling with me at junctions or when i'm slowing down at roundabouts and such like, it does'nt do it all the time just now and again recently though it is starting to get more frequent.

if you any idea's or now what the problem is let me know.

cheers. :rolleyes:

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 DanFraser

DanFraser

    Member

  • New Member
  • PipPip
  • 20 posts
  • Ford Model: Fiesta Cayman 1.3 Ghia
  • Location:

Posted 30 January 2009 - 06:10 PM

Hi,

i have a fiesta 1.25 8V P Reg.

It keeps stalling with me at junctions or when i'm slowing down at roundabouts and such like, it does'nt do it all the time just now and again recently though it is starting to get more frequent.

if you any idea's or now what the problem is let me know.

cheers. :rolleyes:


May sound silly, but have you changed footwear for driving in, or generally? Most things shouldn't be blamed on the car to quickly. You could even be too stressed recently which makes your actions more jerky! Told you it was silly.

If not, then try taking much more care with the clutch and figure out what is actually happening to create the stalls. Try a rolling one on a hill in quiet places (Balance by clutch with no throttle) and see if the bite point changes. Best way is finding a long, more than slight hill, quiet road, and roll backwards never touching the accelerator. Bring your clutch up and hold the car in one position, then creep forward and creep back. Have a few goes and see what the clutch is telling you. If you can't manage that at all, it's clutch problems.

#3 stepheno

stepheno

    Member

  • New Member
  • PipPip
  • 24 posts
  • Ford Model: fiesta mk6

Posted 01 February 2009 - 05:08 PM

sounds like an idle control valve, mine got so bad used to stall while changing gear

#4 mini-st170

mini-st170

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: focus st170

Posted 01 February 2009 - 05:19 PM

its the air flow meter. mine was doing the same thing last week. changed it and fine. roughly 20 quid from breakers

#5 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,482 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 01 February 2009 - 05:26 PM

i would go for the idle controlle valve first, try cleaning with carb cleaner.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users