Jump to content


Photo

Focus Ll 2.0 Tdci Power Loss


  • Please log in to reply
1 reply to this topic

#1 Focus tdci si

Focus tdci si

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: Bagley
  • Ford Model: Focus tdci si
  • Year: 2006
  • Location: Other / Non-UK

Posted 02 April 2012 - 11:24 AM

Hi guys, need help here. My 2006 focus 2.0 tdci si just switched off in traffic one day & would not start after that. Towed the car to a workshop that repairs turbos to replace my manifold gasket as it was leaking (according to Ford). They replaced the gasket, then towed the car to Ford to have it started. The car car then kick started on the way to Ford & has been starting ever since.

Now i have another problem, the car drove to Ford with no power at all. I'm talking about struggling to reach 40, then Ford found one of the thin booster pipes was not attached but that never fixed the problem. I have a cut in the boost pipe leading from the intercooler to the egr & my pipe from the filter box to the turbo has a cut in it.

Could this be the problem to the massive power loss? The car was driving fine prior to it stalling, i still had the cut in the boost pipe which was taped up but the car was driving with no visible smoke & slight power loss after 2500rpm.

Any ideas?

Thanks in advance.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 18,619 posts
  • Name: Clive
  • Ford Model: 2015 Focus ST3 250BHP
  • Year: 2015
  • Location: Devon
Contributor

Posted 02 April 2012 - 11:51 AM

I'd replace any worn or damaged pipes and work from there.
They certainly won't be helping at all.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users