AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
Togger

Cruise Control Not Working.

5 posts in this topic

Just purchased today, a 2008 Mondeo estate, Titanium X 2.0L diesel, manual.

Everything seems fine apart from the cruise control - I can't get it to work.

When you press the button on the left hand side of the wheel it posts a message about cruise control in standby. Then when I press the + or - buttons it just clears the display. Taking my foot off shows it isn't working as the speed drops.

I have a warranty so I can go back to the garage, but wondered if there are any known issues or obvious things to check first. It's just a pain to be without the car so if it's something I could look at then I'd give it a go. There are no fault codes or messages on the dash, it's as if the + or - just cancels cruise control.

Share this post


Link to post
Share on other sites
 

Been out in it today and it's working fine. Guess the first things to check are the clutch and brake switches.

Share this post


Link to post
Share on other sites

Guess the first things to check are the clutch and brake switches.

I'd defo agree with that if it's intermittent.

Share this post


Link to post
Share on other sites

OK, out in the car today and it took loads of attempts to get the cruise control on. Button on the left puts it into standby, but pressing + or - cancels it.

On the motorway I got it to engage eventually, feet now clear of all pedals and system working. I then pressed the + button to increase the speed and it turned the system off. I am now convinced the problem is not with the pedal switches, but with the buttons themselves or the clock spring.

Anyone know how I go about cleaning these up or replacing them? Guide anywhere?

Update - today struggling to get the cruise control system standby on from the button on the left. With buttons on the left and right not working I think I'm going to get a new clock spring.

Share this post


Link to post
Share on other sites

Hi, I have exact same intermittent symptoms as you experienced, can I ask what fixed it in the end and what is a clock spring?

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0