Jump to content


Photo

Needing Help


  • Please log in to reply
2 replies to this topic

#1 Kai_of_lexx

Kai_of_lexx

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: john
  • Ford Model: escort xr3i
  • Year: 1987
  • Location: Durham

Posted 03 April 2012 - 02:52 PM

Hello guys hoping someone can help me out a little, i own a 1987 xri cabby and its got a light problem. Will describe the fault someone may have had it, when u leave the car every now and then the main beam comes on drains the battery. I have found that if i jam the the switch to main beam before i get out it does not do it, that problem i can live with:). My problem now is a friend looked at the while i was working away from with the grand idea of fixing it, he removed all the relays without taking a photo. I have searched for a photo to reinstall them only one i found is a little different to mine, i am hoping someone out there with a 87 cabby can photo theres and e mail me it.

Kai

I dont know yet if members can get my e mail addy from profile if not i can post here ty guys

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 rojariggs

rojariggs

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 419 posts
  • Name: Roger
  • Ford Model: Fiesta 1.6 TDCI Titanium
  • Year: 2011
  • Location: Hertfordshire

Posted 03 April 2012 - 03:11 PM

I would try replacing the main beam switch.

#3 Kai_of_lexx

Kai_of_lexx

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: john
  • Ford Model: escort xr3i
  • Year: 1987
  • Location: Durham

Posted 03 April 2012 - 04:45 PM

Tried that roj had 3 of the damn things :) i can live with that fault tbh the relays pain in the backside 3 easy the others not so.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users