Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


probadumbass

A Couple Of Niggles With My Zetec

2 posts in this topic

Hi

I've recently bought a 2000 (X reg) Fiesta Zetec butt just have a couple of niggles with it that I'm hoping arent too difficult to sort..

1) Central locking - I cant unlock the car from my driver side, I can lock it from that side and the passenger side is fine but I just cant unlock from the driver side.

2) Accelerator feels a little "sticky" to me if that makes sense? I dont feel like its a smooth, continuous motion as I accelerate. Its more like it moves in little increments. e.g. a little pressure does nothing, then i can feel it just 'jump' down slightly rather then being a smooth movement.

I'm not sure if im explaining that very well, its probably worth noting that this is my first car too so I'm a complete newbie, hoping to learn some stuff as I go along though so any help really will be hugely appreciated.

Thanks.

Share this post


Link to post
Share on other sites
 

Hi,

I'd check the door solenoid (locking motor) as they are prone to water getting onto the switches via the door sill seals which perish.

The accelerator pedal problem could be a notchy Throttle Position Sensor.

It's at the top of the pedal and is pretty cheap to replace.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now