• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


ConfusedDaze

Mk7 Auto Folding Mirrors - Cracking Noise

7 posts in this topic

Hi there,

Getting on with Fiesta ownership quite nicely so far apart from a flat the other week.

Anyway - I got in the car this morning and whilst the mirrors were still opening the drivers side one made a loud nasty cracking noise - hasn't done it since and from the look of it - it hasn't been knocked by anything.

Anyone else had them doing this ?

Share this post


Link to post
Share on other sites
 

I know this was an issue with the mk6 but I haven't heard it with the mk7. Mine has certainly never done it. Keep an eye on it and if you notice anything else, take it to the dealership to have a look at it =]

Share this post


Link to post
Share on other sites

I shall thanks for the heads up :)

Im thinking something may have fell inside the mechanism whilst the car was parked and it was crunched whilst opening - its a long shot but thats what I'm thinking.

Share this post


Link to post
Share on other sites

I'm having an issue with my MK6 Fiesta auto fold mirrors whereby on one-side as it closes there is a crack,crack,crack until it closes. Is this a case of take the mirror apart and look for some gear issues?

Share this post


Link to post
Share on other sites

I've had hit before, on more than 1 Fiesta too so it's not uncommon!

I noticed it in cold weather where it was like it had frozen in that position, then come unlocking the door it was like the motors were really working hard against the frost/snow!

I couldn't say what it is but I can only guess it's like the motors are out of sync with the mirror position. It did it when they closed too

Share this post


Link to post
Share on other sites

The motors just run for a set amount of time no syncing but if they have got stuck it can jump the teeth on gearing inside the mirror

Share this post


Link to post
Share on other sites

Does it sound something like the load limiter on a drill driver? If so it will probably be motor gear related, If its a 12/62 plate you still have a warranty why not take it back and ask them to have a look.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now