Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


jack_routledge

Fiesta Mk5 Headunit Wont Work!

2 posts in this topic

Hello..

My firend has a 1999 Mk5 ford fiesta.. he had a sony aftermarket head unit in and he upgraded the head unit to a newer one.. I plugged it in for him and was all working. However he let someone else have a look at it and they pulled it out and apparently the +12v line sparked and now it doesnt turn on. Ive tried changing the fuse in the back of the head unit. Also i ran a live cable drectly from the battery to the back of the unit and it powered on. Could anyone give me any advice, would be much appreciated!

Thanks, Jack!

Share this post


Link to post
Share on other sites
 

Have you checked the fusebox behind the glovebox? A mate of mine once did a similar thing when changing a radio, and all it did was blow a fuse.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now