Jump to content


Photo

Rough Running


  • Please log in to reply
2 replies to this topic

#1 MrRedman

MrRedman

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 85 posts
  • Name: Paul
  • Ford Model: focus 2002
  • Year: 2002
  • Location:

Posted 12 May 2012 - 09:13 AM

Hi cud anyone tell me
On our Mk2 focus the engine management light has come on and it's running rough cud it be the water in the plugs issue as the leads are rusty coloured!
Or would this not trip the management light?
Thanks

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 dezwez

dezwez

    Dezwez

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 4,400 posts
  • Name: Derek
  • Ford Model: ford focus 1.8 zetec mk 2.5
  • Year: 2008
  • Location: Cambridgeshire

Posted 12 May 2012 - 09:27 AM

best thing to do is get your code read that will give you a better idea of whats worng

#3 MrRedman

MrRedman

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 85 posts
  • Name: Paul
  • Ford Model: focus 2002
  • Year: 2002
  • Location:

Posted 12 May 2012 - 10:25 AM

Green flag have been its plug 2 so it's sorted now just need to seal round the washer jets and change all 4 plugs management light is off now also!


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users