Jump to content


Photo

2003 Mondeo Washer Problem


  • Please log in to reply
1 reply to this topic

#1 RugbyMondeo

RugbyMondeo

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: David
  • Ford Model: Mondeo MK 3
  • Year: 2003
  • Location: Warwickshire

Posted 13 May 2012 - 06:17 PM

I have recently brought my second mondeo and have just realised that my washers have a problem. You have to press the stalk in for the front washers to work but on mine you have to do it a few times before any screenwash comes out. I'm guessing that it is just the stalk that is a bit tempremental but after the experience i had with my last mondeo i dont want to start paying money out for different things. If anyone has any infomation on this that can help it would be very much appreciated.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 18,571 posts
  • Name: Clive
  • Ford Model: 2015 Focus ST3 250BHP
  • Year: 2015
  • Location: Devon
Contributor

Posted 13 May 2012 - 06:46 PM

Could be the stalk, the washer pump/filter or just the washer pipes draining back to the tank.
The filter is between the pump and tank and easy to remove once you get to it.
You could try anti syphon valves on the washer pipes.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users