Jump to content


Photo
- - - - -

Fuel In Oil Warning Lamp


  • Please log in to reply
8 replies to this topic

#1 CLGR

CLGR

    Member

  • New Member
  • PipPip
  • 16 posts
  • Name: Claudio
  • Ford Model: Fiesta Titanium Econetic 1.6TDCi
  • Year: 2011
  • Location: Greater London

Posted 20 May 2012 - 07:53 PM

So after tte 12500 service for my Ford Fiesta Titanium Econetic 1.6TDCI, drove it for about 50 mile, now have the Fuel in oil warning light on.

Also have a message Engine oil change due next service.

So isnt oil change part of the service?

What else could cause this.?

Will be onto the phone to dealer 1st thing Monday.

Thanks in advance for any help

Have something to contribute?

Sign in or register to start a topic...

#2 iNath

iNath

    Skoda Driver

  • Super Mod
  • 3,434 posts
  • Name: Nathan
  • Ford Model: Frozen White Fiesta Zetec S TDCi
  • Year: 2010
  • Location: Buckinghamshire
Contributor

Posted 20 May 2012 - 08:27 PM

The light and message is to remind you to have a service done - apparently they can't reset before it's come on so can only be done after you've had the warning.
Had to take mine back to the dealer a week after it's service for them to reset the light - by the looks of things involves pressing both brake and accelerator for 10 seconds whilst turning ignition to stage 2 (though I couldn't swear to it)

#3 CLGR

CLGR

    Member

  • New Member
  • PipPip
  • 16 posts
  • Name: Claudio
  • Ford Model: Fiesta Titanium Econetic 1.6TDCi
  • Year: 2011
  • Location: Greater London

Posted 20 May 2012 - 08:44 PM

Thanks for the reply, have just tried what you suggested, but did not appear to work.

Looks like trip to the dealer later this week :(

#4 iNath

iNath

    Skoda Driver

  • Super Mod
  • 3,434 posts
  • Name: Nathan
  • Ford Model: Frozen White Fiesta Zetec S TDCi
  • Year: 2010
  • Location: Buckinghamshire
Contributor

Posted 20 May 2012 - 09:45 PM

http://www.fordowner...-warning-light/
http://www.fordowner...__1#entry134171

http://rps-mobile-ca...ce-light-reset/

Looks like you may need to press pedals for longer.

#5 CLGR

CLGR

    Member

  • New Member
  • PipPip
  • 16 posts
  • Name: Claudio
  • Ford Model: Fiesta Titanium Econetic 1.6TDCi
  • Year: 2011
  • Location: Greater London

Posted 23 May 2012 - 08:39 PM

Been told by the dealer that you alson need to have seat belt on.

Thanks to all for your help

#6 HelsBels22

HelsBels22

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Fiesta Titanium
  • Location: Aberdeenshire

Posted 17 October 2012 - 10:40 AM

Hi, I've had a similar issue. My Ford Fiesta Titanium went in for it's 1 year manufacturer's service yesterday. Had no warning lights/issues prior to this. It got the all clear, I drove it home without a problem and then this morning when I started the car, the Fuel In Oil Warning Lamp came on and stayed on.

I called the garage and they said it must be a Servicing warning light that they hadn't reset and I just need to bring it in so they can plug it into the computer and clear the code. If this light comes on as a signal to get your car serviced and is a common issue that is easily resolved, why do they not refer to this in the manual rather than letting us panic that the garage cocked up the oil change?

Is it safer to ask them to change the oil anyway or is this "resetting" thing most likely to be the problem. Don't want to do my car any damage unnecessarily, I've only had it a few months and love driving it.

#7 tobyhorne

tobyhorne

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: toby
  • Ford Model: fiesta
  • Year: 2012
  • Location: Essex

Posted 21 February 2013 - 10:14 PM

This happened to my wife's car. Took it for service 800 miles early and then the oil light came on with the squiggle under it and when starting it, it said to have a service. So i came on here read the comments and it was fixed! Thanks everyone!!! So you know how to - get in, put seat belt on, hold down the brake and accelerator, put key in, turn key to position 2 (one before ignition fires up), hold for 60 seconds or more, done.

#8 Bladerunner

Bladerunner

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 152 posts
  • Name: Martin
  • Ford Model: Fiesta Zetec 1.6 tdci 5 door
  • Year: 2010
  • Location: Cumbria

Posted 24 February 2013 - 09:46 AM

Hi Tobyhorne, mine suffered the same -oil can with wavy line below.
I put a topic on here about this recently.
This was about 8,000mls since last oil change.
My garage said might only need sensor re-set but as a precaution they wanted to check oil condition.
Just as well as the oil was very black and not as it should be at this milage.
Oil changed and sensor re-set been ok for about 1,800mls.
Might be a good idea to check oil condition especially tdci versions.
Cheers
Martin

#9 tobyhorne

tobyhorne

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: toby
  • Ford Model: fiesta
  • Year: 2012
  • Location: Essex

Posted 24 February 2013 - 03:26 PM

i dont think it was that but thank you for your concern. we took it for service and oil change at 11800, then somewhere between 12000-12500 the light came on. So it could only have done 500 miles since the oil change max. she's now on 14500ish and the light has not been back on. In this case it was just part of the service warning light.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users