• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Glow plug light sometimes works and sometimes dont

1 post in this topic

Hey all, 1.4 02 TDCI

Have an issue with glow plug light, going do more testing to see if circuit is live when first turn the ignition (being this cold outside it should!). Last few days its been working until yesterday when again no glow plug light and 2 - 3 times to start and idle little lumpy (not loads mind).

I changed the glow plugs for new Ford items (not easy task without rocker off), and brand new hefty battery, seemed better for about 2-3 weeks, back to square one again.

The ecu controls glow plug action via sensor, air inlet temp sensor, any idea where that is? After initial start it then monitors fuel temp and other items for more juice to plugs or not according to Haines, is that right?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now