Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Natasha Langmaid

Need Help And Advice

5 posts in this topic

i have a 2008 focus cc and my engine malfunction warning keeps coming on when i sometimes start the car, it will turn off after i turn off and restart a few time but if i drive with it on the car feels sluggish. also sometimes when starting the car will rev like i have press the pedal to the floor or few times wont start at all unless i pump the pedal please can you advise me i am thinking it may be the acceleration sensor ? how much would this cost to repair ?

Share this post


Link to post
Share on other sites
 

i have a 2008 focus cc and my engine malfunction warning keeps coming on when i sometimes start the car, it will turn off after i turn off and restart a few time but if i drive with it on the car feels sluggish. also sometimes when starting the car will rev like i have press the pedal to the floor or few times wont start at all unless i pump the pedal please can you advise me i am thinking it may be the acceleration sensor ? how much would this cost to repair ?

you be best call in a garage ask cause could be something else causing prob then get a quote when there i bought things for my car thinking it was such thing then wasent

Share this post


Link to post
Share on other sites

get a good local garage to read the stored fault codes, this should point you in the right direction to what the fault is as it could be several different things and will take the guess work out.

Share this post


Link to post
Share on other sites

i actually have a simmilar problem. the Reving issue, when ever i am changing gears.As i lift my foot of the accelarator and it revs on its own...it revs all the way to 3 ( on the rev meter ). what can be the problem

Share this post


Link to post
Share on other sites

Sounds like your throttle position sensor or idle control valve is misbehaving.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now