Jump to content


Photo

O2 Sensor Broken?


  • Please log in to reply
7 replies to this topic

#1 suddste

suddste

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 100 posts
  • Ford Model: Focus LX 1.6L 37,000 mls

Posted 02 June 2012 - 01:36 PM

Hello,

I've been trying to find whats causing my lack of power issue for a while now., I was told to look at the o2 sensor readings but I dont know whats right and whats wrong. I think I may have found that one of the o2 sensors is hardly reading at all but I dont know if my focus has two o2 sensors or not. I have supplied a pic of readings connected to my OBD port. If it turns out my car has two sensors, then I beleive the 2nd (straight line reading) is wrong?

Could it be this sensor thats causing my lack of powerr, and if it is, is it easy/cheap to change?

Attached Thumbnails

  • SC20120602-130141.jpeg


Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 dezwez

dezwez

    Dezwez

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 5,224 posts
  • Name: Derek
  • Ford Model: ford focus 1.8 zetec mk 2.5
  • Year: 2008
  • Location: Cambridgeshire

Posted 02 June 2012 - 02:38 PM

hi if yours is a 1998 to 2005 it should have two one before the cat and one after the cat need two have a good look
i dont no about the later petrol ones

#3 suddste

suddste

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 100 posts
  • Ford Model: Focus LX 1.6L 37,000 mls

Posted 02 June 2012 - 03:00 PM

hi if yours is a 1998 to 2005 it should have two one before the cat and one after the cat need two have a good look
i dont no about the later petrol ones


thats correct, mine is a 2004 mk1.5

#4 david295

david295

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 282 posts
  • Name: David
  • Ford Model: Fiesta
  • Year: 2011
  • Location: Cheshire

Posted 02 June 2012 - 03:02 PM

Mine is a 1998 to 2005 and only has 1 before cat, the other hole is blocked off, and no wiring for it

#5 dezwez

dezwez

    Dezwez

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 5,224 posts
  • Name: Derek
  • Ford Model: ford focus 1.8 zetec mk 2.5
  • Year: 2008
  • Location: Cambridgeshire

Posted 02 June 2012 - 03:05 PM

then theres are two look over the back of the engine bay you will see the frist one there it in the down pipe the second one is under the car
just after the cat hope this helps

#6 suddste

suddste

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 100 posts
  • Ford Model: Focus LX 1.6L 37,000 mls

Posted 02 June 2012 - 03:41 PM

then theres are two look over the back of the engine bay you will see the frist one there it in the down pipe the second one is under the car
just after the cat hope this helps


thanks, but do you know if the pic looks right for o2 sensors? I thought they should be both alternating like the one on the left

#7 dezwez

dezwez

    Dezwez

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 5,224 posts
  • Name: Derek
  • Ford Model: ford focus 1.8 zetec mk 2.5
  • Year: 2008
  • Location: Cambridgeshire

Posted 02 June 2012 - 03:47 PM

someone should be along that can tell you that just post the picture
again your better waiting till the evening more members on line

#8 suddste

suddste

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 100 posts
  • Ford Model: Focus LX 1.6L 37,000 mls

Posted 02 June 2012 - 04:49 PM

someone should be along that can tell you that just post the picture
again your better waiting till the evening more members on line


thanks

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users