Jump to content


Help Me Please!!!

  • Please log in to reply
No replies to this topic

#1 burnsy5shoes



  • New Member
  • Pip
  • 2 posts
  • Name: Scott
  • Ford Model: Ford Focus
  • Year: 2005
  • Location: Lanarkshire

Posted 02 June 2012 - 05:44 PM

I have a 05 ford focus lx but having a few problems. When I start the car up the, the red light starts flashing on the dash (think its for the immobiliser, the car shudders and after a few seconds the car cuts out. The battery light comes on like the car has stalled. This happens a few times before I press the accelerator and the car eventually moves off but the light continues to flash for a few mins after driving. I took this to a mechanic and he ran it through his diagnostic machine and all that came back was it was a transponder error and he advised me to contact a key guy as it sounded like a battery fault. Phoned the key guy and he said its not a key fault. Car keeps doing it all the time and now my radio won't work as its needed a code, I'm beginning to this there may be an electrical fault but wishing to see if anyone can help on here before the ford garage takes a few hundred quid off me!!!

Also my car shakes a lot when going more than 60 mph and the rev counter is about 3500 revs, is this normal???

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users