Jump to content


Photo

How To Clean My Injectors ?


  • Please log in to reply
5 replies to this topic

#1 brooksey

brooksey

    Member

  • New Member
  • PipPip
  • 12 posts
  • Name: liam
  • Ford Model: mondeo mk3
  • Year: 2003
  • Location: Norfolk

Posted 04 June 2012 - 01:22 PM

Hi i bought a mk3 mondeo 2.0 tdci which is running abit lumpy also limp mode kicks in when i try to overtake on the motorway
could any of you talk me through the best way of cleanning them / does and donts and ive heard they are coded ect

thanks
liam

Have something to contribute?

Sign in or register to start a topic...

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,457 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 04 June 2012 - 08:10 PM

if they are sent away for cleaning as long as the same injector goes into there origanal position they will not have to be recoded back to the car, any new or recon injectors will have to be recoded, are you shure its the injectors at fault? get a leak of test done to confirm this, when was the fuel filter last changed as an old filter could also give the porblems you have.

#3 brooksey

brooksey

    Member

  • New Member
  • PipPip
  • 12 posts
  • Name: liam
  • Ford Model: mondeo mk3
  • Year: 2003
  • Location: Norfolk

Posted 04 June 2012 - 08:58 PM

ive only just serviced the car at the weekend and thought that would help ive also put injector cleaner through it. how much would it cost to send them away to be cleaned ?

the cars running rough at idle which i thought would be to do with the injectors when driveing it pulls smooth if you try to overtake or accelerate hard in 5th the car goes in to limp mode and sometimes just cut out soon as you turn off and on its ok

its driving me crazy lol

cheers liam

#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,457 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 05 June 2012 - 07:22 AM

you could try cleaning the egr valve and see if there is any improvement.

#5 brooksey

brooksey

    Member

  • New Member
  • PipPip
  • 12 posts
  • Name: liam
  • Ford Model: mondeo mk3
  • Year: 2003
  • Location: Norfolk

Posted 05 June 2012 - 10:05 AM

update ive cleaned the egr valve even did the inlet and still running rough going to drive it today and see what its like might take afew miles to settle after removing inlet ect

#6 Z3 MON

Z3 MON

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 328 posts
  • Name: David
  • Ford Model: Ford Mondeo 2.0 TDCI 115 Mistral 2004
  • Year: 2004
  • Location: Surrey

Posted 06 June 2012 - 12:25 PM

Was the fuel filter changed with a Bosch, Delphi, ford or motor factor part?
Is there any knocking noises?
Does The roughness go away if you rev a little ?
What's your mileage ect?

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users