• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


emlo68

12V Power Socket

4 posts in this topic

Hi,

Does anyone know where I can get a replacement 12V power outlet socket for a 2006 Ford Focus Zetec Climate. I have tried changing the fuse but still not working. Trawled around ebay, breakers websites for a replacement but with no luck so far.

Also, is it easy to fit a replacement if I manage to find one?

Many thanks in advance !! :D

Share this post


Link to post
Share on other sites
 

Hi,

Does anyone know where I can get a replacement 12V power outlet socket for a 2006 Ford Focus Zetec Climate. I have tried changing the fuse but still not working. Trawled around ebay, breakers websites for a replacement but with no luck so far.

Also, is it easy to fit a replacement if I manage to find one?

Many thanks in advance !! :D

very easy to replace it mate,

the loom is a moulded orange plug and the socket just plugs straight in to it,

id check the connection at the rear of your socket as it may have come loose and lost power to the socket.

Share this post


Link to post
Share on other sites

Hey hey!

Would it be the same for mine??

& where/how do you mean by rear of socket to check connection??

Thanks in advance!

Share this post


Link to post
Share on other sites

Hey hey!

Would it be the same for mine??

& where/how do you mean by rear of socket to check connection??

Thanks in advance!

Hi,

by checking the connection i ment that the plug which goes on to the 12v socket at the rear of the unit may have come loose resulting in no power going to the socket, in his case their was no power in the centre 12v dash socket,

and i have checked and diagrams for the mk6 fiesta is limited but i reckon the socket is in place,

you just need to plug in the 12v socket to it,

see image:

Fiesta1-1.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now