Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Bodger

Apparent Uneven Engine With Loss Of Power At Medium Revs

8 posts in this topic

I have an 02 Tdci that has developed a loss of power or hic-cup at medium revs, if you accelerate hard there is no problem. Does anyone have any ideas where I start looking and what the problem is likely to be?

Thanks in anticipation,

Share this post


Link to post
Share on other sites
 

Sorry all, it's an 04 model, I am obviously loosing the plot!!

Share this post


Link to post
Share on other sites

Sounds like a clogged EGR.

I'm sure someone else here will give tips on how to remove it and clean it up.

Share this post


Link to post
Share on other sites

I have the same on a light throttle at 1500 rpm , and its not my egr or fuel filter, doesnt seem to be injectors, have had this fault for the last 8000miles

Share this post


Link to post
Share on other sites

if the egr is ok check for a split intercooler hose,its the large hose from the bottom of the egr valve.

Share this post


Link to post
Share on other sites

Not the intercooler hose either on mine

Share this post


Link to post
Share on other sites

also try checking the turbo boost pipe which runs up the front of the engine on the left as you look at it. these can also split giving the hic up as the turbo spools up.

Share this post


Link to post
Share on other sites

also try checking the turbo boost pipe which runs up the front of the engine on the left as you look at it. these can also split giving the hic up as the turbo spools up.

Not that on mine been through most things all seems well only happens at 1500rpm on a light to trailing throttle

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now