Jump to content


Show
Photo

Ford Galaxy Not Starting


  • Please log in to reply
1 reply to this topic

#1 1Hutcho

1Hutcho

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: Mark
  • Ford Model: Galaxy
  • Year: 1998
  • Location: Leicestershire

Posted 18 June 2012 - 11:27 AM

Hi everyone, i'm new to this so please bear with me!. Right I have a ford galaxy 1998 (s) 2.3 petrol. I've had it quite awhile and its never let me down, until Friday night. Basically I filled the car up with the mrs and kids, turned the ignition on turned the key, the engine turned but wouldn't fire up. I tried this about 5-6 times then the battery died. Next day I got a neighbour to jump start me and the car started fine, I used it all weekend with no problems. Today I have come to go to work and the same problem has occured, but this time i have noticed that when I turn the ignition on i dont hear the buzz of the fuel pump, has anyone got any ideas that i could try before I take it to a garage? Thanks in advance, Mark.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 gregers

gregers

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 512 posts
  • Name: greg
  • Ford Model: smax titainium
  • Year: 2008
  • Location: Sussex

Posted 18 June 2012 - 07:01 PM

if you dont get an answer here,then try asking here ;) ,

www.fordmpv.com
or
www.fordgalaxy.org.uk


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users