Jump to content


Photo

V6 mondeo missing!


  • Please log in to reply
2 replies to this topic

#1 trooper30

trooper30

    Member

  • New Member
  • PipPip
  • 11 posts
  • Ford Model: Mondeo
  • Location:

Posted 10 February 2009 - 01:03 PM

Hi fellas, just picked up a manual 98 mondeo V6 GhiaX which Im prety pleased with.
One thing I have noticed, when drivig it hard up throught the gears it starts to miss a few beats, almost starts missing! This only happens when you get close to the redline moving up the box, close to redline, starts mising!
Totaly fine trrough the rest of the rev range though
Any ideas fellas?

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,467 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 10 February 2009 - 05:56 PM

could be the rev limiter kicking in.

#3 trooper30

trooper30

    Member

  • New Member
  • PipPip
  • 11 posts
  • Ford Model: Mondeo
  • Location:

Posted 10 February 2009 - 06:46 PM

could be the rev limiter kicking in.



Rev limiter? Didnt know it had one, and ideas how I disconect that then? lol :rolleyes:


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users