• Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience


daniel_hine81

C-Max completely dead

4 posts in this topic

Hi folks

I have a 53 plate 2.0 tdci zetec and after driving the car this afternoon, there is now no power at all to it. I went to pick up my daughter from school and noticed the Ignition warning light still on, parked up at the school and after getting the little one, started up again and had the same issue. Set off up the road and then lost power steering, ABS and ESP, started to slow down and the car then just cut out completely. All the electrics are completely dead, there is nothing! :-( I had someone come along to try a jumpstart but still no joy, no power at all. I phoned Ford and they want £80 (1 hour labour) just to run a diagnostic check on it.... anyone know if it could just be a battery/alternator fault or could it be more sinister??

Could I just take it to Kwikfit or somewhere like that for them to test for a battery fault as they normally do it free of charge??

Unfortunately, I can't afford to pay out to get it fixed or anything at the moment, as sod's law would have it, I spent all my spare money for this month getting the Kitchen and Bathrooms re-tiled!!!!

Any help greatly appreciated

Many thanks

Dan

Share this post


Link to post
Share on other sites
 

oh and just to add, the car was making a fairly quiet whining noise during the time the Ignition warning light came on

Share this post


Link to post
Share on other sites

sounds like the alternator isnt producing a high enough output or the battery is fubarred. get both of them load tested if you can, places like kwik fit will do it for free in hope of a sale. i personally dont recommend kwik fit though but if its the only place you can get it to you dont have a choice.

one check you could do though is make sure the alternator belt is still in place.

Share this post


Link to post
Share on other sites

don't know if this is sorted yet but there is a very large (high current fuse) just on the front of the battery location case which I know gives this sort of fault where everything goes dead

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now