Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


tayn

Focus Tdci 1.8 Red Warning Light, No Power

3 posts in this topic

Hi all,

1st (half decent) ford iv owned, got to say its a great car :) i usually go for audi/bmw/vw but fancied a change!

anyway got hold of this little guy, tdci 1.8 (think its a sport) had a full ST replica done, seats bodykit rims dash trims pretty much everything, and a matt black finish looks pretty good!

anyway been running alright for about 2k, then 3 days ago stalled on me (i was giving enough revs) and a light came on, on the left in a cog shape with a ! inside. didnt think nothing of it as it went away thought maybe it was like another version of ESP or sumin i dno.

anyway 2 days later same thing, stall light on, this time i had to turn off and on to reset. now today it happend, im noticing its usually when i pull of quickly, today was reversing, going into 1st gear and pulling off. this time the light will not go, and iv noticed since its been on i have next to no power, i struggle to get to 30 in 3rd gear without having to do 4000+ rev. and definetly will not go above 40 without sounding like its 100!

my mechanics more german car orientated so hes not sure, havent had a chance to get him round to run faults yet probably wont for few days. my mate who is a focus owner also thinks either camshaft sensors or the EGR valve going a bit mad, but does anyone know the exact problem or had this before?

any help would be ideal :(

thanks

tayn

Share this post


Link to post
Share on other sites
 

it sounds like the car has gone into limp home mode, this happens on the tdciwhen there is an engine problem to prevent poss damage, you will have to get the fault codes read to point towards what the problem might be.

Share this post


Link to post
Share on other sites

fault codes advised glow plug module, and also a seperate fault for cooling fan. my mechanic only took 15 mins to have a quick look as he was busy having a proper look next week. would a glowplug module failing put the car into limp mode? and is it safe to drive in limp mode if im careful? thanks for the reply :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now