Jump to content


Show
Photo

Sierra Coswoth Running Problems!


  • Please log in to reply
2 replies to this topic

#1 willadl

willadl

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: focus st
  • Location:

Posted 01 July 2012 - 07:58 PM

Hi, I am at my wits end trying to figure out what's causing running problems with my sierra cosy. The car is jumpy when trying to drive normally when it starts acting up and jumping the rev needle drops to 0 for a few seconds. At higher revs over 2000 the car runs fine. I have had the problem for about 4 years and tried numourus things to remedy this problem but no luck. It's driving me mad and if anyone has any ideas what could be up or had the same problems i would really appreciate help!

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,465 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 02 July 2012 - 01:55 PM

on the bulkhead their should be three electrical plugs in the wiring loom,try cleaning the contacts in these and see if the car improves.

#3 willadl

willadl

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: focus st
  • Location:

Posted 03 July 2012 - 09:06 PM

Hi mate will def try this and let you know hopefully will sort it.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users