Jump to content


Photo

Burning Oil


  • Please log in to reply
2 replies to this topic

#1 Drich290195

Drich290195

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 226 posts
  • Name: David
  • Ford Model: Focus 1.8 TDCi
  • Year: 2006
  • Location: Yorkshire

Posted 07 July 2012 - 10:38 AM

Just checked my oil and it's just above minimum , it's done 7000 miles since its last service bit I don't remember checkin the oil level on the dipstick after that service to be honest. I think t was burning a bit of oil when I ha my glow plug fault. Does this sound ok oil usage is their anything to worry about. Is it worth topping up till my next service. Not noticed any oil under the car. It's a 1.8tdci engine 56 plate with 60k on the clock. As always cheers for your advice

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon

btmaldon

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,581 posts
  • Name: Bruce
  • Ford Model: BMW 320i Coupe M Sport, KA Luxury
  • Year: 2008
  • Location: Essex

Posted 07 July 2012 - 05:23 PM

Its only used less than half a litre in 7000 miles wich is pretty good. Some cars use oil some dont. Manufacturers normally specify up to 1 litre per 1000 miles as being ok. So nothing to worry about.

#3 Drich290195

Drich290195

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 226 posts
  • Name: David
  • Ford Model: Focus 1.8 TDCi
  • Year: 2006
  • Location: Yorkshire

Posted 07 July 2012 - 06:22 PM

Cool cheers mate


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users