Jump to content


ford galaxy 1.9td

  • Please log in to reply
2 replies to this topic

#1 lfc



  • New Member
  • Pip
  • 1 posts
  • Ford Model: galaxy 1.9td
  • Location:

Posted 13 February 2009 - 09:02 AM

i have the above car and have probs starting i am told there is no power to the glow plugs and i will have to have a switch installed to bypass the relay to heat the glowplugs just wonder if anyone else has had this problem

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin


    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,576 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 13 February 2009 - 11:57 PM

i do not understand why the relay would need to be bypassed, has the relay and glow plug fuses been checked for power?

#3 sr-performance


    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 147 posts
  • Ford Model: Ford Escort Van TDDI
  • Year: 2014
  • Location:

Posted 15 February 2009 - 04:47 PM

find a good auto sparky to have a look at it mate, cant be much wrong with it, might just be the glow plug heater relay? also when you come to sell it and you then have to explain to poss new owner about your fancy starting technique... :)


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users