Jump to content


Mondeo Mk3 2001. Climate Control Issues !!

  • Please log in to reply
No replies to this topic

#1 royzee



  • New Member
  • Pip
  • 3 posts
  • Ford Model: mondeo
  • Location:

Posted 15 July 2012 - 09:00 AM

Hope someone can throw some light on this for me.
Have the auto climate control with the three round dials.
The first selects hot and cold, and Auto. The centre is the display screen and the right hand is the selector for where the air is directed.
In the distant past I have had a problem where it wont blow hot air. Have reset the control panel and all was well.
The problem now is that I can only seem to get air through the windscreen vent. If I select anything else, it seems like all the vents are shut but the fan is running. Tried resetting the controls, no faults found. Tried again, no fault found.
On using this reset procedure about a year ago for a different problem, I think I heard the flaps operate, now however, the flaps do not move.
Initially thought its the motor for the flap.
Upon further investigation I have found this.
If I select Auto and Lo, the blower fan comes on full, but no flaps open. AC light is not lit. Press AC button and it lights, Auto disappears from screen but no flaps open. Press AC again, light goes out,and all flaps open but Auto still not on screen.

If I use the manual fan control set to fast and Lo temp, all flaps are closed but fan runs high. Then select windscreen, AC light comes on and windscreen flap opens. If I press the AC button it wont go out ( cant remember if this is correct). If I try to select any other vent, none will open.

Turn it off and again use manual control set to fast and Lo temp, again all flaps are closed. Press any other flap button, nothing happens, BUT if I then press the AC button the button lights, still no flaps open, BUT, if I press the button again, the lamp goes out AND that flap opens ! This happens for the footwell, face and up flaps.

Because I can get all the flaps to open at some point, it seems unlikely its a motor. So I suspected the control unit.
Have replaced control unit and no difference, exactly the same problem, again no faults show when i run the test.

I am at a bit of a loss.
Any ideas please??


Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users