Jump to content


Photo

New coils and have vibration


  • Please log in to reply
No replies to this topic

#1 devilskabanaboy

devilskabanaboy

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: mondeo 2001
  • Location:

Posted 14 February 2009 - 02:25 PM

Hi there. 6 weeks ago i got a new coil fitted to front left of my 2001 mondeo. Then last week on MOT- i had to have a new coil and bearing for the front right.

After the first visit of the MOT, i had to take it back due to a grinding noise. They diagnosed it as the coil had come out. They fixed, but I took back the next day due to vibrations. Transpires that the bearing exploded and they had to re-do it all again.

I now still have some vibrations. So got it tracked and balanced- but that didnt solve it.

Upon self inspection- it appears that the front left "coil spacer" ( looks like the top of ice cream cone and made of solid plastic ) has been fitted upside down ( opposite way to front right ). Also- the rubber bush/bung has dropped down.

Would this be the cause of my vibration?

I know that in theory i should have felt after first change 6 weeks back- but with my right hand coil broken- wouldnt it have dropped the right side slightly therefore taking the weight off the left side- and hence hiding the problem?

Any help would be great before i take back to the garage for 5th time!!! Many Thanks

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users