Jump to content


Photo

Escort 55D Van 1998, Headlights Not Working


  • Please log in to reply
2 replies to this topic

#1 RobH291

RobH291

    Newbie

  • Members via FB
  • Pip
  • 3 posts
  • Name: Rob
  • Ford Model: Escort 55d van
  • Year: 1999
  • Location: Hampshire

Posted 21 July 2012 - 01:30 PM

the headlights on my Escort van are not working, the main beam works and flashes but no sidelights or headlights when you turn them on normally? The fuses are ok having just been changed, any ideas please?

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 Lenny

Lenny

    Retired Moderator

  • FOC Supporters
  • 11,376 posts
  • Name: Leonard
  • Ford Model: Mk2.5 Focus ZetecS 1.6TDCi superleggero
  • Year: 2010
  • Location: Ireland
Contributor

Posted 21 July 2012 - 01:46 PM

the headlights on my Escort van are not working, the main beam works and flashes but no sidelights or headlights when you turn them on normally? The fuses are ok having just been changed, any ideas please?


sounds like a bad earth connection mate,
check the earth points around the engine bay and headlight areas.

#3 RobH291

RobH291

    Newbie

  • Members via FB
  • Pip
  • 3 posts
  • Name: Rob
  • Ford Model: Escort 55d van
  • Year: 1999
  • Location: Hampshire

Posted 21 July 2012 - 01:55 PM

thanks but earth points are ok as works fine on beam,must be something else. Tnanks anyway


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users