Jump to content


Show
Photo

streetka 52. clutch problems. thrust bearing maybe?


  • Please log in to reply
1 reply to this topic

#1 anita-

anita-

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: streetka 2003
  • Location:

Posted 15 February 2009 - 12:12 PM

Hi,

second problem!

Im pretty sure the clutch bearing has gone, when the clutch isnt engaged when stationary there is a "whirring" noise, when the clutch is engaged it seems to dissaper.

I have noticed a couple of times when pulling away in all gears at low revs there is an unusual noise.

Would i be correct in thinking its the thrust bearing?

Also what i am not to sure about is that the clutch has slipped whilst in gear a couple of times, noticable third and fourth and usually when coming of a roundabout. Its definitly feeling and sounding like the clutch isnt biting theres no pull.

The thing is it doesnt do it all the time, hardly at all. and it seems to pull well in fifth gear from quite low down.


could it be related to the first problem?

Thanks in advance, would really appreciate help as only had the car for a week.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,461 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 15 February 2009 - 02:31 PM

you are right in saying it sounds like the thrust bearing starting to break down, replacement is the only option and you might as well do the clutch why the box is removed.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users